summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Lindvall2021-05-21 11:14:46 +0200
committerMarius Lindvall2021-05-21 11:14:46 +0200
commit3f1156b998b63788945be71002ac485b91193bb8 (patch)
treebdd9c1fd3624acf7a88a538477cc96785c7e7dd3
downloadaur-3f1156b998b63788945be71002ac485b91193bb8.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a928cdc9136
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = apertium-eng-cat
+ pkgdesc = Apertium translation pair for English and Catalan
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/apertium/apertium-eng-cat
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = pkgconf
+ makedepends = autoconf
+ depends = apertium>=3.4.2
+ depends = apertium-lex-tools
+ depends = apertium-separable
+ depends = apertium-anaphora
+ depends = vislcg3
+ depends = apertium-eng
+ depends = apertium-cat
+ source = apertium-eng-cat-1.0.1.tar.gz::https://github.com/apertium/apertium-eng-cat/archive/refs/tags/v1.0.1.tar.gz
+ sha256sums = 5cf72219db1fb8ac43649e3c90b545ee1acbee96620c778d7084fb3bec743dc6
+
+pkgname = apertium-eng-cat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a234a0acfef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Marius Lindvall <(firstname) {cat} varden {dog} info>
+# Contributor: Kevin Brubeck Unhammer <unhammer@fsfe.org>
+pkgname=apertium-eng-cat
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Apertium translation pair for English and Catalan"
+url="https://github.com/apertium/${pkgname}"
+license=('GPL3')
+makedepends=('pkgconf' 'autoconf')
+depends=('apertium>=3.4.2' 'apertium-lex-tools' 'apertium-separable' 'apertium-anaphora' 'vislcg3' 'apertium-eng' 'apertium-cat')
+arch=('i686' 'x86_64')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/apertium/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('5cf72219db1fb8ac43649e3c90b545ee1acbee96620c778d7084fb3bec743dc6')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}