summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brubeck Unhammer2015-07-14 10:22:30 +0200
committerKevin Brubeck Unhammer2015-07-14 10:22:30 +0200
commit9f19b6803a625b9942657351160af9455a7fa915 (patch)
tree5f60a512516a46fa239610bd46c05c2cbfabb656
downloadaur-9f19b6803a625b9942657351160af9455a7fa915.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--Makefile.am.patch37
-rw-r--r--PKGBUILD32
-rw-r--r--configure.ac.patch19
4 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c823141841fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = apertium-eo-ca
+ pkgdesc = Apertium language data for the Esperanto-Catalan translator.
+ pkgver = 0.9.1
+ pkgrel = 2
+ url = http://apertium.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ depends = lttoolbox>=3.0
+ depends = apertium>=3.0
+ source = http://downloads.sourceforge.net/sourceforge/apertium/apertium-eo-ca-0.9.1.tar.gz
+ source = Makefile.am.patch
+ source = configure.ac.patch
+ md5sums = 75b027c23e031bfdb645fbd120e82d72
+ md5sums = 99ff6b39e16ef8314a82951414bb2d66
+ md5sums = 4695b4ad4f6eb089b528bef0d2820a3f
+
+pkgname = apertium-eo-ca
+
diff --git a/Makefile.am.patch b/Makefile.am.patch
new file mode 100644
index 000000000000..d8bb61a65aa7
--- /dev/null
+++ b/Makefile.am.patch
@@ -0,0 +1,37 @@
+--- ../apertium-eo-ca-0.9.1/Makefile.am 2009-07-04 17:23:58.000000000 +0200
++++ apertium-eo-ca-0.9.1/Makefile.am 2010-09-15 15:41:11.000000000 +0200
+@@ -32,7 +32,7 @@
+ $(PREFIX1).autogen.bin: $(BASENAME).$(LANG1).dix
+ apertium-validate-dictionary $(BASENAME).$(LANG1).dix
+ lt-comp rl $(BASENAME).$(LANG1).dix $@
+-
++
+ $(BASENAME).$(LANG1).dix.translit: $(BASENAME).$(LANG1).dix
+ ./transliterate.sh $(BASENAME).$(LANG1).dix >$@
+
+@@ -43,7 +43,7 @@
+ $(PREFIX1).autopgen.bin: $(BASENAME).post-$(LANG1).dix
+ apertium-validate-dictionary $(BASENAME).post-$(LANG1).dix
+ lt-comp lr $(BASENAME).post-$(LANG1).dix $@
+-
++
+ $(BASENAME).post-$(LANG1).dix.translit: $(BASENAME).post-$(LANG1).dix
+ ./transliterate.sh $(BASENAME).post-$(LANG1).dix >$@
+
+@@ -122,11 +122,11 @@
+
+ install-data-local:
+ apertium-gen-modes modes.xml apertium-$(PREFIX1)
+- $(INSTALL_DATA) $(PREFIX1).mode $(apertium_eo_camodesdir)
+- $(INSTALL_DATA) $(PREFIX2).mode $(apertium_eo_camodesdir)
+- $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t1x $(BASENAME).$(PREFIX1).t2x $(apertium_eo_cadir)
+- $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t3x $(BASENAME).$(PREFIX1).t1x.translit $(apertium_eo_cadir)
+- $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t2x.translit $(BASENAME).$(PREFIX1).t3x.translit $(apertium_eo_cadir)
++ $(INSTALL_DATA) $(PREFIX1).mode $(DESTDIR)$(apertium_eo_camodesdir)
++ $(INSTALL_DATA) $(PREFIX2).mode $(DESTDIR)$(apertium_eo_camodesdir)
++ $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t1x $(BASENAME).$(PREFIX1).t2x $(DESTDIR)$(apertium_eo_cadir)
++ $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t3x $(BASENAME).$(PREFIX1).t1x.translit $(DESTDIR)$(apertium_eo_cadir)
++ $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t2x.translit $(BASENAME).$(PREFIX1).t3x.translit $(DESTDIR)$(apertium_eo_cadir)
+
+
+ CLEANFILES = -rf $(TARGETS) *.translit modes
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38344551bff9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Kevin Brubeck Unhammer <unhammer@gmail.com>
+# Maintainer: Kevin Brubeck Unhammer <unhammer@gmail.com>
+pkgname=apertium-eo-ca
+pkgver=0.9.1
+pkgrel=2
+pkgdesc="Apertium language data for the Esperanto-Catalan translator."
+url="http://apertium.org"
+license=('GPL')
+makedepends=('pkgconfig')
+depends=('lttoolbox>=3.0' 'apertium>=3.0')
+arch=('i686' 'x86_64')
+source=("http://downloads.sourceforge.net/sourceforge/apertium/${pkgname}-${pkgver}.tar.gz"
+ "Makefile.am.patch"
+ "configure.ac.patch")
+md5sums=('75b027c23e031bfdb645fbd120e82d72'
+ '99ff6b39e16ef8314a82951414bb2d66'
+ '4695b4ad4f6eb089b528bef0d2820a3f')
+
+build() {
+ patch -p0 < Makefile.am.patch
+ patch -p0 < configure.ac.patch
+
+ mkdir -p "$pkgdir/usr/share/apertium/modes"
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ autoreconf -i
+
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir/" install || return 1
+} \ No newline at end of file
diff --git a/configure.ac.patch b/configure.ac.patch
new file mode 100644
index 000000000000..c5b7076740cd
--- /dev/null
+++ b/configure.ac.patch
@@ -0,0 +1,19 @@
+--- ../apertium-eo-ca-0.9.1/configure.ac 2009-07-04 17:19:42.000000000 +0200
++++ apertium-eo-ca-0.9.1/configure.ac 2010-09-21 15:53:29.670738778 +0200
+@@ -19,8 +19,14 @@
+ APERTIUM_VER=30
+ ],
+ [
+- PKG_CHECK_MODULES(APERTIUM, apertium-3.1 >= 3.1.0)
+- APERTIUM_VER=31
++ PKG_CHECK_MODULES(APERTIUM, apertium-3.1 >= 3.1.0,
++ [
++ APERTIUM_VER=31
++ ],
++ [
++ PKG_CHECK_MODULES(APERTIUM, apertium-3.2 >= 3.2.0)
++ APERTIUM_VER=32
++ ])
+ ])
+ AC_SUBST(APERTIUM_VER)
+ ])