summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brubeck Unhammer2015-07-14 10:22:40 +0200
committerKevin Brubeck Unhammer2015-07-14 10:22:40 +0200
commit04511427c3a14d49611a6f1a9082a64ae0fd7674 (patch)
tree286b8153a0abbd467c2a1fd3690388f6fe2e69aa
downloadaur-04511427c3a14d49611a6f1a9082a64ae0fd7674.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--Makefile.am.patch15
-rw-r--r--PKGBUILD27
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6951c0181e25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = apertium-eo-fr
+ pkgdesc = Apertium language data for the Esperanto-French translator.
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = http://apertium.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ depends = lttoolbox>=3.0
+ depends = apertium>=3.0
+ source = http://downloads.sourceforge.net/sourceforge/apertium/apertium-eo-fr-0.9.0.tar.gz
+ source = Makefile.am.patch
+ md5sums = c3c4efa6e8faa990ae213a1707a1bd63
+ md5sums = 74b0b10ddcc8bf3f64613dca3f2c34b0
+
+pkgname = apertium-eo-fr
+
diff --git a/Makefile.am.patch b/Makefile.am.patch
new file mode 100644
index 000000000000..98535465d3de
--- /dev/null
+++ b/Makefile.am.patch
@@ -0,0 +1,15 @@
+--- apertium-eo-fr-0.9.0/Makefile.am.orig 2011-05-28 13:14:57.955419683 +0400
++++ apertium-eo-fr-0.9.0/Makefile.am 2011-05-28 13:16:12.248463272 +0400
+@@ -90,9 +90,9 @@
+
+ install-data-local:
+ apertium-gen-modes modes.xml apertium-$(PREFIX1)
+- $(INSTALL_DATA) $(PREFIX1).mode $(apertium_eo_camodesdir)
+- $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t1x $(BASENAME).$(PREFIX1).antaux1_t2x $(BASENAME).$(PREFIX1).antaux2_t2x $(BASENAME).$(PREFIX1).antaux3_t2x $(BASENAME).$(PREFIX1).antaux4_t2x $(BASENAME).$(PREFIX1).t2x $(BASENAME).$(PREFIX1).post_t2x $(apertium_eo_cadir)
+- $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t3x $(apertium_eo_cadir)
++ $(INSTALL_DATA) $(PREFIX1).mode $(DESTDIR)$(apertium_eo_camodesdir)
++ $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t1x $(BASENAME).$(PREFIX1).antaux1_t2x $(BASENAME).$(PREFIX1).antaux2_t2x $(BASENAME).$(PREFIX1).antaux3_t2x $(BASENAME).$(PREFIX1).antaux4_t2x $(BASENAME).$(PREFIX1).t2x $(BASENAME).$(PREFIX1).post_t2x $(DESTDIR)$(apertium_eo_cadir)
++ $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t3x $(DESTDIR)$(apertium_eo_cadir)
+
+
+ # $(INSTALL_DATA) $(PREFIX2)-pn.mode $(apertium_es_modesdir)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f83369eff15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=apertium-eo-fr
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="Apertium language data for the Esperanto-French translator."
+url="http://apertium.org"
+license=('GPL')
+makedepends=('pkgconfig')
+depends=('lttoolbox>=3.0' 'apertium>=3.0')
+arch=('i686' 'x86_64')
+source=("http://downloads.sourceforge.net/sourceforge/apertium/${pkgname}-${pkgver}.tar.gz"
+ "Makefile.am.patch")
+md5sums=('c3c4efa6e8faa990ae213a1707a1bd63'
+ '74b0b10ddcc8bf3f64613dca3f2c34b0')
+
+build() {
+ patch -p0 < Makefile.am.patch
+
+ mkdir -p "$pkgdir/usr/share/apertium/modes"
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ autoreconf -i
+
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir/" install || return 1
+}