summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brubeck Unhammer2015-07-14 10:22:58 +0200
committerKevin Brubeck Unhammer2015-07-14 10:22:58 +0200
commit7f5d1088ada1e882ee04080009cb46680843a427 (patch)
treed791f59f30ee9d0787b1b0134e604ece98b684fb
downloadaur-7f5d1088ada1e882ee04080009cb46680843a427.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--Makefile.am.patch46
-rw-r--r--PKGBUILD35
-rw-r--r--configure.ac.patch42
-rw-r--r--trules.patch56
5 files changed, 202 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2100e280c99e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = apertium-es-ro
+ pkgdesc = Apertium language data for the Spanish-Romanian translator.
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = http://apertium.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ makedepends = autoconf
+ depends = lttoolbox>=3.0
+ depends = apertium>=3.0
+ source = http://downloads.sourceforge.net/sourceforge/apertium/apertium-es-ro-0.7.1.tar.gz
+ source = Makefile.am.patch
+ source = configure.ac.patch
+ source = trules.patch
+ md5sums = 9de6e21ddf8dfb65a6b09b430e8ab600
+ md5sums = e0d964dad84346f98b500505d428b687
+ md5sums = f4067b2a28d94dc08feff01a41f2d107
+ md5sums = 0a6caa9170cca54ba1146803e6cdb1e6
+
+pkgname = apertium-es-ro
+
diff --git a/Makefile.am.patch b/Makefile.am.patch
new file mode 100644
index 000000000000..7f41f13edf75
--- /dev/null
+++ b/Makefile.am.patch
@@ -0,0 +1,46 @@
+--- ../apertium-es-ro-0.7.1/Makefile.am 2007-10-11 21:06:30.000000000 +0200
++++ apertium-es-ro-0.7.1/Makefile.am 2010-09-15 17:21:24.000000000 +0200
+@@ -49,7 +49,7 @@
+ apertium-validate-transfer $(BASENAME).trules-$(PREFIX1).xml
+ apertium-preprocess-transfer $(BASENAME).trules-$(PREFIX1).xml \
+ trules-$(PREFIX1).bin
+-
++
+ trules-$(PREFIX2).bin: $(BASENAME).trules-$(PREFIX2).xml
+ apertium-validate-transfer $(BASENAME).trules-$(PREFIX2).xml
+ apertium-preprocess-transfer $(BASENAME).trules-$(PREFIX2).xml \
+@@ -67,7 +67,7 @@
+ $(BASENAME).$(LANG2).tsx $(BASENAME).trules-$(PREFIX1).xml \
+ $(BASENAME).trules-$(PREFIX2).xml $(PREFIX1).prob $(PREFIX2).prob \
+ modes.xml
+-
++
+ apertium_es_rodir=$(prefix)/share/apertium/apertium-$(PREFIX1)/
+ apertium_es_modesdir=$(prefix)/share/apertium/modes/
+
+@@ -79,20 +79,21 @@
+
+ modes: modes.xml
+ apertium-gen-modes modes.xml
+-
++
+ apertium_es_ro_DATA=$(PREFIX1).automorf.bin $(PREFIX2).automorf.bin \
+ $(PREFIX1).autobil.bin $(PREFIX2).autobil.bin \
+ $(PREFIX1).autogen.bin $(PREFIX2).autogen.bin \
+ $(PREFIX1).autopgen.bin $(PREFIX2).autopgen.bin \
+ $(PREFIX1).prob $(PREFIX2).prob trules-$(PREFIX1).xml \
+ trules-$(PREFIX2).xml trules-$(PREFIX1).bin \
+- trules-$(PREFIX2).bin $(PREFIX1).mode $(PREFIX2).mode
++ trules-$(PREFIX2).bin $(PREFIX2).mode
+
+ install-data-local:
+ apertium-gen-modes modes.xml apertium-$(PREFIX1)
++ $(INSTALL_DATA) $(PREFIX2).mode $(DESTDIR)$(apertium_es_modesdir)
++ $(INSTALL_DATA) $(BASENAME).trules-$(PREFIX2).xml $(BASENAME).trules-$(PREFIX1).xml $(DESTDIR)$(apertium_es_rodir)
++
+ # spanish -> romanian is not currently functional ~fmt
+ # $(INSTALL_DATA) $(PREFIX1).mode $(apertium_es_modesdir)
+- $(INSTALL_DATA) $(PREFIX2).mode $(apertium_es_modesdir)
+- $(INSTALL_DATA) $(BASENAME).trules-$(PREFIX2).xml $(BASENAME).trules-$(PREFIX1).xml $(apertium_es_rodir)
+
+ CLEANFILES = -rf $(TARGETS) modes
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6c82a0615a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Kevin Brubeck Unhammer <unhammer@gmail.com>
+# Maintainer: Kevin Brubeck Unhammer <unhammer@gmail.com>
+pkgname=apertium-es-ro
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="Apertium language data for the Spanish-Romanian translator."
+url="http://apertium.org"
+license=('GPL')
+makedepends=('pkgconfig' 'autoconf')
+depends=('lttoolbox>=3.0' 'apertium>=3.0')
+arch=('i686' 'x86_64')
+source=("http://downloads.sourceforge.net/sourceforge/apertium/${pkgname}-${pkgver}.tar.gz"
+ "Makefile.am.patch"
+ "configure.ac.patch"
+ "trules.patch")
+md5sums=('9de6e21ddf8dfb65a6b09b430e8ab600'
+ 'e0d964dad84346f98b500505d428b687'
+ 'f4067b2a28d94dc08feff01a41f2d107'
+ '0a6caa9170cca54ba1146803e6cdb1e6')
+
+build() {
+ patch -p0 < Makefile.am.patch
+ patch -p0 < configure.ac.patch
+ patch -p0 < trules.patch
+
+ mkdir -p "$pkgdir/usr/share/apertium/modes"
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ autoreconf -i
+
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir/" install || return 1
+}
diff --git a/configure.ac.patch b/configure.ac.patch
new file mode 100644
index 000000000000..11d0e3e47591
--- /dev/null
+++ b/configure.ac.patch
@@ -0,0 +1,42 @@
+--- ../apertium-es-ro-0.7.1/configure.ac 2007-10-11 21:06:44.000000000 +0200
++++ apertium-es-ro-0.7.1/configure.ac 2010-09-15 17:16:41.000000000 +0200
+@@ -12,7 +12,37 @@
+ AC_PROG_AWK
+ AC_CONFIG_HEADER([config])
+
+-PKG_CHECK_MODULES(apertium, [dnl
+- apertium-3.0 >= required_apertium_version])
++AC_DEFUN([PKG_CHECK_APERTIUM], [
++ APERTIUM_VER=0
++ PKG_CHECK_MODULES(APERTIUM, apertium-1.0 >= 1.0.0,
++ [
++ APERTIUM_VER=10
++ ],
++ [
++ PKG_CHECK_MODULES(APERTIUM, apertium-2.0 >= 2.0.0,
++ [
++ APERTIUM_VER=20
++ ],
++ [
++ PKG_CHECK_MODULES(APERTIUM, apertium-3.0 >= 3.0.0,
++ [
++ APERTIUM_VER=30
++ ],
++ [
++ PKG_CHECK_MODULES(APERTIUM, apertium-3.1 >= 3.1.0,
++ [
++ APERTIUM_VER=31
++ ],
++ [
++ PKG_CHECK_MODULES(APERTIUM, apertium-3.2 >= 3.2.0)
++ APERTIUM_VER=32
++ ])
++ ])
++ ])
++ ])
++ AC_SUBST(APERTIUM_VER)
++])
++
++PKG_CHECK_APERTIUM
+
+ AC_OUTPUT([Makefile])
diff --git a/trules.patch b/trules.patch
new file mode 100644
index 000000000000..352f03e65573
--- /dev/null
+++ b/trules.patch
@@ -0,0 +1,56 @@
+--- ../apertium-es-ro-0.7.1/apertium-es-ro.trules-ro-es.xml 2007-10-11 21:04:49.000000000 +0200
++++ apertium-es-ro-0.7.1/apertium-es-ro.trules-ro-es.xml 2010-09-15 17:18:56.000000000 +0200
+@@ -4545,8 +4545,6 @@
+ <clip pos="3" side="sl" part="a_case"/>
+ <lit-tag v="nom"/>
+ </equal>
+- </and>
+- <and>
+ <equal>
+ <clip pos="4" side="sl" part="a_def"/>
+ <lit-tag v="def"/>
+@@ -4676,8 +4674,6 @@
+ <clip pos="2" side="sl" part="a_case"/>
+ <lit-tag v="nom"/>
+ </equal>
+- </and>
+- <and>
+ <equal>
+ <clip pos="3" side="sl" part="a_def"/>
+ <lit-tag v="def"/>
+@@ -4984,8 +4980,6 @@
+ <clip pos="2" side="sl" part="a_case"/>
+ <lit-tag v="nom"/>
+ </equal>
+- </and>
+- <and>
+ <equal>
+ <clip pos="3" side="sl" part="a_def"/>
+ <lit-tag v="def"/>
+@@ -5115,8 +5109,6 @@
+ <clip pos="2" side="sl" part="a_case"/>
+ <lit-tag v="nom"/>
+ </equal>
+- </and>
+- <and>
+ <equal>
+ <clip pos="3" side="sl" part="a_def"/>
+ <lit-tag v="def"/>
+@@ -5757,7 +5749,7 @@
+ </call-macro>
+ <choose>
+ <when>
+- <test>
++ <test><and>
+ <equal>
+ <clip pos="1" side="sl" part="a_case"/>
+ <lit-tag v="nom"/>
+@@ -5766,7 +5758,7 @@
+ <clip pos="1" side="sl" part="a_def"/>
+ <lit-tag v="def"/>
+ </equal>
+- </test>
++ </and></test>
+ <call-macro n="modcase">
+ <with-param pos="1"/>
+ </call-macro>