summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Lindvall2021-05-21 00:28:42 +0200
committerMarius Lindvall2021-05-21 00:28:42 +0200
commit0fd67a0f04d3b5350ad5f676bad498e4d92bc94a (patch)
tree2645b9aea982c8cfc9b370c84db466550019560f
downloadaur-apertium-fin.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f55d625d9294
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = apertium-fin
+ pkgdesc = Finnish monolingual data and morphological analyser-generator for apertium
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/apertium/apertium-fin
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = pkgconf
+ depends = apertium>=3.4.2
+ depends = vislcg3
+ depends = hfst
+ source = apertium-fin-0.0.2.tar.gz::https://github.com/apertium/apertium-fin/archive/refs/tags/v0.0.2.tar.gz
+ sha256sums = 865fb5f258b1ab9417c2fe9473340e86e21673c236b31b2909dfa6f8b9a56892
+
+pkgname = apertium-fin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef2234275f39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Marius Lindvall <(firstname) {cat} varden {dog} info>
+pkgname=apertium-fin
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="Finnish monolingual data and morphological analyser-generator for apertium"
+url="https://github.com/apertium/${pkgname}"
+license=('GPL3')
+makedepends=('pkgconf')
+depends=('apertium>=3.4.2' 'vislcg3' 'hfst')
+arch=('i686' 'x86_64')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/apertium/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('865fb5f258b1ab9417c2fe9473340e86e21673c236b31b2909dfa6f8b9a56892')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./autogen.sh --prefix=/usr
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}