summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brubeck Unhammer2015-07-14 10:23:35 +0200
committerKevin Brubeck Unhammer2015-07-14 10:23:35 +0200
commitcaeaab48efbf71b09fab06fb279491bf909f3599 (patch)
tree8dbae3c7cba421a37ee369298ab60b0bf0614d92
downloadaur-caeaab48efbf71b09fab06fb279491bf909f3599.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--Makefile.am.patch29
-rw-r--r--PKGBUILD32
-rw-r--r--configure.ac.patch19
4 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a3bdfe86274
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = apertium-pt-ca
+ pkgdesc = Apertium language data for the Portuguese-Catalan translator.
+ pkgver = 0.8.1
+ pkgrel = 2
+ url = http://apertium.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ makedepends = autoconf
+ depends = lttoolbox>=3.0
+ depends = apertium>=3.0
+ source = http://downloads.sourceforge.net/sourceforge/apertium/apertium-pt-ca-0.8.1.tar.gz
+ source = Makefile.am.patch
+ source = configure.ac.patch
+ md5sums = 615df78d702ca48bf96c55f2d3eaf1f9
+ md5sums = 4faa12bc68e3f7190f71de562328872c
+ md5sums = 7db5c971f2d683acb51d44d4e5d44f67
+
+pkgname = apertium-pt-ca
+
diff --git a/Makefile.am.patch b/Makefile.am.patch
new file mode 100644
index 000000000000..623921ce9821
--- /dev/null
+++ b/Makefile.am.patch
@@ -0,0 +1,29 @@
+--- ../apertium-pt-ca-0.8.1/Makefile.am 2009-03-04 09:23:13.000000000 +0100
++++ apertium-pt-ca-0.8.1/Makefile.am 2010-09-15 16:02:22.000000000 +0200
+@@ -69,7 +69,7 @@
+ rm $(BASENAME).$(LANG1).dix
+ rm $(BASENAME).$(LANG2).dix
+ rm $(BASENAME).$(PREFIX1).dix
+-
++
+ apertium_pt_cadir=$(prefix)/share/apertium/apertium-$(PREFIX1)/
+ apertium_pt_modesdir=$(prefix)/share/apertium/modes/
+
+@@ -88,12 +88,12 @@
+ $(PREFIX1).t1x.bin \
+ $(PREFIX2).t1x.bin \
+ $(PREFIX1).mode $(PREFIX2).mode modes.xml
+-
++
+ install-data-local:
+ apertium-gen-modes modes.xml apertium-$(PREFIX1)
+- $(INSTALL_DATA) $(PREFIX1).mode $(apertium_pt_modesdir)
+- $(INSTALL_DATA) $(PREFIX2).mode $(apertium_pt_modesdir)
+- $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t1x $(apertium_pt_cadir)
+- $(INSTALL_DATA) $(BASENAME).$(PREFIX2).t1x $(apertium_pt_cadir)
++ $(INSTALL_DATA) $(PREFIX1).mode $(DESTDIR)$(apertium_pt_modesdir)
++ $(INSTALL_DATA) $(PREFIX2).mode $(DESTDIR)$(apertium_pt_modesdir)
++ $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t1x $(DESTDIR)$(apertium_pt_cadir)
++ $(INSTALL_DATA) $(BASENAME).$(PREFIX2).t1x $(DESTDIR)$(apertium_pt_cadir)
+
+ CLEANFILES = -rf $(TARGETS_COMMON) modes
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b38d2c83f030
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Kevin Brubeck Unhammer <unhammer@gmail.com>
+# Maintainer: Kevin Brubeck Unhammer <unhammer@gmail.com>
+pkgname=apertium-pt-ca
+pkgver=0.8.1
+pkgrel=2
+pkgdesc="Apertium language data for the Portuguese-Catalan translator."
+url="http://apertium.org"
+license=('GPL')
+makedepends=('pkgconfig' 'autoconf')
+depends=('lttoolbox>=3.0' 'apertium>=3.0')
+arch=('i686' 'x86_64')
+source=("http://downloads.sourceforge.net/sourceforge/apertium/${pkgname}-${pkgver}.tar.gz"
+ "Makefile.am.patch"
+ "configure.ac.patch")
+md5sums=('615df78d702ca48bf96c55f2d3eaf1f9'
+ '4faa12bc68e3f7190f71de562328872c'
+ '7db5c971f2d683acb51d44d4e5d44f67')
+
+build() {
+ patch -p0 < Makefile.am.patch
+ patch -p0 < configure.ac.patch
+
+ mkdir -p "$pkgdir/usr/share/apertium/modes"
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ autoreconf -i
+
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir/" install || return 1
+} \ No newline at end of file
diff --git a/configure.ac.patch b/configure.ac.patch
new file mode 100644
index 000000000000..d0d0a65aa237
--- /dev/null
+++ b/configure.ac.patch
@@ -0,0 +1,19 @@
+--- ../apertium-pt-ca-0.8.1/configure.ac 2009-03-04 09:23:25.000000000 +0100
++++ apertium-pt-ca-0.8.1/configure.ac 2010-09-21 16:33:40.230738778 +0200
+@@ -19,8 +19,14 @@
+ APERTIUM_VER=30
+ ],
+ [
+- PKG_CHECK_MODULES(APERTIUM, apertium-3.1 >= 3.1.0)
+- APERTIUM_VER=31
++ PKG_CHECK_MODULES(APERTIUM, apertium-3.1 >= 3.1.0,
++ [
++ APERTIUM_VER=31
++ ],
++ [
++ PKG_CHECK_MODULES(APERTIUM, apertium-3.2 >= 3.2.0)
++ APERTIUM_VER=32
++ ])
+ ])
+ AC_SUBST(APERTIUM_VER)
+ ])