summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc Riera2022-04-19 22:43:39 +0200
committerMarc Riera2022-04-19 22:43:39 +0200
commit5d9ae0823ee9aec13aff42da0285a7d293749a7a (patch)
tree440ae7b0d16e8cefd492b57e7e09f44f50fc9f81
parent4a7e846225d448a2b3adf360fb7ec2a2e3c7834c (diff)
downloadaur-5d9ae0823ee9aec13aff42da0285a7d293749a7a.tar.gz
Fix missing dependency from lttoolbox
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3546af702355..0cff4333ec6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,7 @@ pkgbase = apertium-recursive
makedepends = pkgconf
makedepends = autoconf
makedepends = gcc
+ makedepends = utf8cpp
depends = lttoolbox>=3.6.0
depends = apertium>=3.8.0
depends = libxml2>=2.6.17
diff --git a/PKGBUILD b/PKGBUILD
index 98356111ba1d..879121020673 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,13 @@ pkgdesc="A recursive structural transfer module for Apertium"
arch=('i686' 'x86_64')
url="https://wiki.apertium.org/wiki/Apertium-recursive"
license=('GPL3')
-makedepends=('pkgconf' 'autoconf' 'gcc')
+makedepends=('pkgconf' 'autoconf' 'gcc' 'utf8cpp')
depends=('lttoolbox>=3.6.0' 'apertium>=3.8.0' 'libxml2>=2.6.17' 'pcre' 'icu')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/apertium/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
sha256sums=('a741bed2f6917a835927f7098f1df92f3d616f09d7674ffc03ca99db0e3f5c0e')
build() {
+ export CXXFLAGS="$CXXFLAGS -I/usr/include/utf8cpp"
cd "$srcdir/$pkgname-$pkgver"
./autogen.sh --prefix=/usr
make