summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brubeck Unhammer2017-11-02 23:03:57 +0100
committerKevin Brubeck Unhammer2017-11-02 23:05:38 +0100
commit8e10a0ec78f15acc37445601f114e6b862962fff (patch)
treec6f8cde28869e382bfa6015acc14452b8bad52eb
downloadaur-8e10a0ec78f15acc37445601f114e6b862962fff.tar.gz
apertium-separable-svn; but depends on newer version of lttoolbox
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..049c0f80a617
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = apertium-separable-svn
+ pkgdesc = Language-independent machine translation engine and tools to manage language data.
+ pkgver = 0.1.1.r83053
+ pkgrel = 1
+ url = http://apertium.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = svn
+ depends = apertium>=3.4.2
+ options = !libtool
+ source = svn://svn.code.sf.net/p/apertium/svn/branches/apertium-separable
+ md5sums = SKIP
+
+pkgname = apertium-separable-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94fc942ad5a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Kevin Brubeck Unhammer <unhammer@fsfe.org>
+# Maintainer: Kevin Brubeck Unhammer <unhammer@fsfe.org>
+pkgname=apertium-separable-svn
+pkgver=0.1.1.r83053
+pkgrel=1
+pkgdesc="Language-independent machine translation engine and tools to manage language data."
+url="http://apertium.org"
+license=('GPL2')
+makedepends=('svn')
+depends=('apertium>=3.4.2')
+options=('!libtool')
+arch=('i686' 'x86_64')
+source=("svn://svn.code.sf.net/p/apertium/svn/branches/apertium-separable")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/apertium-separable"
+ local ver="$(svnversion)"
+ printf "%s" "0.1.1.r${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "$srcdir/apertium-separable"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/apertium-separable"
+ make DESTDIR="$pkgdir/" install
+}