summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brubeck Unhammer2015-07-14 10:23:42 +0200
committerKevin Brubeck Unhammer2015-07-14 10:23:42 +0200
commit16a48612047ea7cedb96ba85dc1c169cafdb8b5a (patch)
tree1e3cdf9e42668a087f6184c614ae2e8078562d89
downloadaur-16a48612047ea7cedb96ba85dc1c169cafdb8b5a.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--Makefile.am.patch35
-rw-r--r--PKGBUILD32
-rw-r--r--configure.ac.patch19
4 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20ff3aab1cf0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = apertium-sv-da
+ pkgdesc = Apertium language data for the Swedish-Danish translator.
+ pkgver = 0.5.0
+ pkgrel = 2
+ url = http://apertium.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ makedepends = autoconf
+ depends = lttoolbox>=3.0
+ depends = apertium>=3.0
+ source = http://downloads.sourceforge.net/sourceforge/apertium/apertium-sv-da-0.5.0.tar.gz
+ source = Makefile.am.patch
+ source = configure.ac.patch
+ md5sums = 23d4247a7eb4835a096737a20251bc78
+ md5sums = 276a049384b15d77c6b5164315b593e4
+ md5sums = ba12ab1b519a4853478cf27104639e23
+
+pkgname = apertium-sv-da
+
diff --git a/Makefile.am.patch b/Makefile.am.patch
new file mode 100644
index 000000000000..13542d70c49a
--- /dev/null
+++ b/Makefile.am.patch
@@ -0,0 +1,35 @@
+--- ../apertium-sv-da-0.5.0/Makefile.am 2009-09-22 14:53:23.000000000 +0200
++++ apertium-sv-da-0.5.0/Makefile.am 2010-09-15 15:34:16.000000000 +0200
+@@ -53,7 +53,7 @@
+ apertium-validate-transfer $(BASENAME).$(PREFIX2).t1x
+ apertium-preprocess-transfer $(BASENAME).$(PREFIX2).t1x \
+ $(PREFIX2).t1x.bin
+-
++
+
+ $(PREFIX1).mode: modes.xml
+ apertium-gen-modes modes.xml
+@@ -68,7 +68,7 @@
+ $(BASENAME).$(LANG2).dix $(BASENAME).$(LANG1).tsx \
+ $(BASENAME).$(LANG2).tsx $(BASENAME).$(PREFIX1).t1x \
+ $(BASENAME).$(PREFIX2).t1x $(PREFIX1).prob $(PREFIX2).prob modes.xml
+-
++
+ apertium_sv_modesdir=$(prefix)/share/apertium/modes/
+ apertium_sv_dadir=$(prefix)/share/apertium/apertium-$(PREFIX1)/
+ apertium_sv_da_DATA=$(PREFIX1).automorf.bin $(PREFIX2).automorf.bin \
+@@ -82,10 +82,10 @@
+
+ install-data-local:
+ apertium-gen-modes modes.xml apertium-$(PREFIX1)
+- $(INSTALL_DATA) $(PREFIX1).mode $(apertium_sv_modesdir)
+- $(INSTALL_DATA) $(PREFIX2).mode $(apertium_sv_modesdir)
+- $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t1x $(apertium_sv_dadir)
+- $(INSTALL_DATA) $(BASENAME).$(PREFIX2).t1x $(apertium_sv_dadir)
++ $(INSTALL_DATA) $(PREFIX1).mode $(DESTDIR)$(apertium_sv_modesdir)
++ $(INSTALL_DATA) $(PREFIX2).mode $(DESTDIR)$(apertium_sv_modesdir)
++ $(INSTALL_DATA) $(BASENAME).$(PREFIX1).t1x $(DESTDIR)$(apertium_sv_dadir)
++ $(INSTALL_DATA) $(BASENAME).$(PREFIX2).t1x $(DESTDIR)$(apertium_sv_dadir)
+ cp *.mode modes/
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9e9c52b7cbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Kevin Brubeck Unhammer <unhammer@gmail.com>
+# Maintainer: Kevin Brubeck Unhammer <unhammer@gmail.com>
+pkgname=apertium-sv-da
+pkgver=0.5.0
+pkgrel=2
+pkgdesc="Apertium language data for the Swedish-Danish translator."
+url="http://apertium.org"
+license=('GPL')
+makedepends=('pkgconfig' 'autoconf')
+depends=('lttoolbox>=3.0' 'apertium>=3.0')
+arch=('i686' 'x86_64')
+source=("http://downloads.sourceforge.net/sourceforge/apertium/${pkgname}-${pkgver}.tar.gz"
+ "Makefile.am.patch"
+ "configure.ac.patch")
+md5sums=('23d4247a7eb4835a096737a20251bc78'
+ '276a049384b15d77c6b5164315b593e4'
+ 'ba12ab1b519a4853478cf27104639e23')
+
+build() {
+ patch -p0 < Makefile.am.patch
+ patch -p0 < configure.ac.patch
+
+ mkdir -p "$pkgdir/usr/share/apertium/modes"
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ autoreconf -i
+
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir/" install || return 1
+} \ No newline at end of file
diff --git a/configure.ac.patch b/configure.ac.patch
new file mode 100644
index 000000000000..e986d2c9b0f4
--- /dev/null
+++ b/configure.ac.patch
@@ -0,0 +1,19 @@
+--- ../apertium-sv-da-0.5.0/configure.ac 2009-09-22 14:47:25.000000000 +0200
++++ apertium-sv-da-0.5.0/configure.ac 2010-09-21 16:39:20.487405444 +0200
+@@ -19,8 +19,14 @@
+ APERTIUM_VER=30
+ ],
+ [
+- PKG_CHECK_MODULES(APERTIUM, apertium-3.1 >= 3.1.0)
+- APERTIUM_VER=31
++ PKG_CHECK_MODULES(APERTIUM, apertium-3.1 >= 3.1.0,
++ [
++ APERTIUM_VER=31
++ ],
++ [
++ PKG_CHECK_MODULES(APERTIUM, apertium-3.2 >= 3.2.0)
++ APERTIUM_VER=32
++ ])
+ ])
+ AC_SUBST(APERTIUM_VER)
+ ])