summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIdo Kanner2019-07-06 17:52:25 +0300
committerIdo Kanner2019-07-06 17:52:25 +0300
commitd70481af79122dd4e7d13f20b492ba34ef1b6177 (patch)
tree5297693c2c54bae5afa51d91e8a3dea304d6101e
downloadaur-d70481af79122dd4e7d13f20b492ba34ef1b6177.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ab81dc79cd3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = apex-up
+ pkgdesc = Deploy infinitely scalable serverless apps, apis, and sites in seconds to AWS
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://up.docs.apex.sh/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = binutils
+ provides = apex-up
+ source_i686 = up::https://github.com/apex/up/releases/download/v1.3.0/up_1.3.0_linux_386.tar.gz
+ sha256sums_i686 = eafb20bb2c1884ee14082d37184bfc04db7dd4df041cd90c6ff54c9513a6dc9e
+ source_x86_64 = up::https://github.com/apex/up/releases/download/v1.3.0/up_1.3.0_linux_amd64.tar.gz
+ sha256sums_x86_64 = 03753b9f388a2d33f7f5d61cd8a34b06dcca85c2a6b3ae70ebcb31bdcc95f939
+
+pkgname = apex-up
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de1472d42fe3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Ido Kanner <idokan@gmail.com>
+pkgname=apex-up
+_pkgname=up
+pkgdesc="Deploy infinitely scalable serverless apps, apis, and sites in seconds to AWS"
+pkgver=1.3.0
+pkgrel=1
+arch=('i686' 'x86_64')
+license=('MIT')
+url='https://up.docs.apex.sh/'
+provides=('apex-up')
+noextract=()
+makedepends=('binutils')
+
+[[ "$CARCH" == "i686" ]] && _arch="386"
+[[ "$CARCH" == "x86_64" ]] && _arch="amd64"
+
+_local_name="${_pkgname}_linux_${_arch}"
+
+source_i686=("${_pkgname}::https://github.com/apex/up/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_386.tar.gz")
+source_x86_64=("${_pkgname}::https://github.com/apex/up/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.tar.gz")
+sha256sums_i686=('eafb20bb2c1884ee14082d37184bfc04db7dd4df041cd90c6ff54c9513a6dc9e')
+sha256sums_x86_64=('03753b9f388a2d33f7f5d61cd8a34b06dcca85c2a6b3ae70ebcb31bdcc95f939')
+
+prepare() {
+ strip "${_pkgname}"
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/bin
+ install -Dm0755 "$_pkgname" "$pkgdir"/usr/bin
+}
+