summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-05 21:05:41 +0100
committerBartłomiej Piotrowski2018-01-05 21:05:41 +0100
commit55b085b9bcc3e9a34a5a0d519410ee6d2aa818cf (patch)
tree797604776f69ef45a7a67596dcffa824cea6a46c
downloadaur-55b085b9bcc3e9a34a5a0d519410ee6d2aa818cf.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO13
-rw-r--r--ChangeLog3
-rw-r--r--PKGBUILD30
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f45b6acb1b8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = apg
+ pkgdesc = Automated Password Generator.
+ pkgver = 2.2.3
+ pkgrel = 4
+ url = http://www.adel.nursat.kz/apg/index.shtml
+ arch = x86_64
+ license = custom
+ depends = glibc
+ source = http://www.adel.nursat.kz/apg/download/apg-2.2.3.tar.gz
+ md5sums = 3b3fc4f11e90635519fe627c1137c9ac
+
+pkgname = apg
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..811f87d4f1ec
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,3 @@
+2007-06-28 tardo <tardo@nagi-fanboi.net>
+* Built for x86_64
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5dcd54a18ec1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: eric <eric@archlinux.org>
+# Contributor: Manolis Tzanidakis
+
+pkgname=apg
+pkgver=2.2.3
+pkgrel=4
+pkgdesc="Automated Password Generator."
+arch=(x86_64)
+url="http://www.adel.nursat.kz/apg/index.shtml"
+license=('custom')
+depends=('glibc')
+source=(http://www.adel.nursat.kz/apg/download/$pkgname-$pkgver.tar.gz)
+md5sums=('3b3fc4f11e90635519fe627c1137c9ac')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ sed -i 's:^#\(CS_LIBS = -lnsl\)$:\1:' Makefile
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in apg apgbfm; do
+ install -D -m755 $i "$pkgdir"/usr/bin/$i
+ install -D -m644 doc/man/$i.1 "$pkgdir"/usr/share/man/man1/$i.1
+ done
+ install -D -m 644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}