summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWinni Neessen2021-10-24 22:13:36 +0200
committerWinni Neessen2021-10-24 22:13:36 +0200
commit47134831edd5e39d894a74afac76e9fff4c3888d (patch)
tree18afaf3655d38bcfe2d46bfeae589f6d21b70ced
parent9c6abf415e45797bfadc873b62c4f8eeac9fe3a7 (diff)
downloadaur-47134831edd5e39d894a74afac76e9fff4c3888d.tar.gz
Update to v0.4.0
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD8
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d76ed281112..3b2508087fb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = apg-go
- pkgdesc = A "Automated Password Generator"-clone
- pkgver = 0.3.2
- pkgrel = 1
- url = https://github.com/wneessen/apg-go
- arch = i686
- arch = x86_64
- arch = armv6h
- arch = armv7h
- arch = aarch64
- license = MIT
- makedepends = go
- source = https://github.com/wneessen/apg-go/archive/refs/tags/v0.3.2.tar.gz
- sha256sums = 42f082d2f54d1cb20e1d6d63c1d923255b711151c937041f64164180758ce0e4
+ pkgdesc = A "Automated Password Generator"-clone
+ pkgver = 0.4.0
+ pkgrel = 2
+ url = https://github.com/wneessen/apg-go
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = go
+ source = https://github.com/wneessen/apg-go/archive/refs/tags/v0.4.0.tar.gz
+ sha256sums = 21704158cbf9ae34d821169ff755a8381fd6b6b0d52d243fbb4a893c84bf6f4c
pkgname = apg-go
-
diff --git a/PKGBUILD b/PKGBUILD
index 16a07607768e..f5c8cd4d4728 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: "Winni Neessen (https://pebcak.de)
pkgname=apg-go
-pkgver=0.3.2
-pkgrel=1
+pkgver=0.4.0
+pkgrel=2
pkgdesc='A "Automated Password Generator"-clone'
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url='https://github.com/wneessen/apg-go'
license=('MIT')
makedepends=('go')
source=("https://github.com/wneessen/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('42f082d2f54d1cb20e1d6d63c1d923255b711151c937041f64164180758ce0e4')
+sha256sums=('21704158cbf9ae34d821169ff755a8381fd6b6b0d52d243fbb4a893c84bf6f4c')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -18,7 +18,7 @@ prepare() {
build() {
cd "${pkgname}-${pkgver}"
- go build -ldflags="-s -w" -o build/${pkgname} ./...
+ go build -ldflags="-s -w" -o build/${pkgname} github.com/wneessen/apg-go/cmd/apg
}
package() {