summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraphototool2022-03-08 12:05:29 +0200
committeraphototool2022-03-08 12:05:29 +0200
commit003b926b9e1c7d89b220dc845372b60c0438d605 (patch)
treec797fd0007bf97295750a852052667323749ced3
parentdc03593ccda557d73dd41bf26b64648d76434c97 (diff)
downloadaur-003b926b9e1c7d89b220dc845372b60c0438d605.tar.gz
Version 1.0.2-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71153f30c664..d0bf1b72675d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = aphototoollibre
pkgdesc = Photo editor for Linux
- pkgver = 1.0.1
- pkgrel = 2
+ pkgver = 1.0.2
+ pkgrel = 1
url = https://www.ahola.me/aphototoollibre.html
arch = x86_64
license = GPL3
depends = qt5-base>=5.15.2
depends = hicolor-icon-theme
- source = aphototoollibre-1.0.1-2-src.tar.gz::https://github.com/aphototool/A-Photo-Tool-Libre/archive/refs/tags/v1.0.1-2.tar.gz
- source = aphototoollibre-1.0.1-2-src.tar.gz.asc::https://github.com/aphototool/A-Photo-Tool-Libre/releases/download/v1.0.1-2/v1.0.1-2.tar.gz.asc
+ source = aphototoollibre-1.0.2-1-src.tar.gz::https://github.com/aphototool/A-Photo-Tool-Libre/archive/refs/tags/v1.0.2-1.tar.gz
+ source = aphototoollibre-1.0.2-1-src.tar.gz.asc::https://github.com/aphototool/A-Photo-Tool-Libre/releases/download/v1.0.2-1/v1.0.2-1.tar.gz.asc
validpgpkeys = A970F7E40CB64F0D5B9FC516AFE56C2DF614820C
- sha256sums = 42f22e1c294c89704cd564365b2519981ef02f3c9b95f176c6d243fd6c420d98
+ sha256sums = 2197498de0059392a62621f7c7e696d0d54bb57779b82e442d6ba89849e12c73
sha256sums = SKIP
pkgname = aphototoollibre
diff --git a/PKGBUILD b/PKGBUILD
index 083768595ae4..df304ed111e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jari Ahola <aphototool@ahola.me>
pkgname=aphototoollibre
-pkgver=1.0.1
-pkgrel=2
+pkgver=1.0.2
+pkgrel=1
pkgdesc="Photo editor for Linux"
arch=('x86_64')
url="https://www.ahola.me/aphototoollibre.html"
@@ -10,7 +10,7 @@ depends=('qt5-base>=5.15.2' 'hicolor-icon-theme')
makedepends=()
source=("$pkgname-$pkgver-$pkgrel-src.tar.gz::https://github.com/aphototool/A-Photo-Tool-Libre/archive/refs/tags/v$pkgver-$pkgrel.tar.gz"
"$pkgname-$pkgver-$pkgrel-src.tar.gz.asc::https://github.com/aphototool/A-Photo-Tool-Libre/releases/download/v$pkgver-$pkgrel/v$pkgver-$pkgrel.tar.gz.asc")
-sha256sums=('42f22e1c294c89704cd564365b2519981ef02f3c9b95f176c6d243fd6c420d98' 'SKIP')
+sha256sums=('2197498de0059392a62621f7c7e696d0d54bb57779b82e442d6ba89849e12c73' 'SKIP')
validpgpkeys=('A970F7E40CB64F0D5B9FC516AFE56C2DF614820C')
build() {
@@ -21,12 +21,10 @@ build() {
package() {
cd "$srcdir/A-Photo-Tool-Libre-$pkgver-$pkgrel"
- mkdir -p "$pkgdir/usr/bin"
- mkdir -p "$pkgdir/usr/share/applications"
- mkdir -p "$pkgdir/usr/share/icons/hicolor/scalable/apps"
- mkdir -p "$pkgdir/usr/share/metainfo"
- cp "$srcdir/A-Photo-Tool-Libre-$pkgver-$pkgrel/bin/APhotoToolLibre" "$pkgdir/usr/bin/"
- cp "$srcdir/A-Photo-Tool-Libre-$pkgver-$pkgrel/desktop/me.ahola.aphototoollibre.desktop" "$pkgdir/usr/share/applications/"
- cp "$srcdir/A-Photo-Tool-Libre-$pkgver-$pkgrel/desktop/me.ahola.APhotoToolLibre.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/"
- cp "$srcdir/A-Photo-Tool-Libre-$pkgver-$pkgrel/desktop/me.ahola.aphototoollibre.metainfo.xml" "$pkgdir/usr/share/metainfo/"
+ install -Dm755 "bin/aphototoollibre" "$pkgdir/usr/bin/aphototoollibre"
+ install -Dm644 "debian/aphototoollibre.1.gz" "$pkgdir/usr/share/man/man1/aphototoollibre.1.gz"
+ install -Dm644 "desktop/me.ahola.aphototoollibre.desktop" "$pkgdir/usr/share/applications/me.ahola.aphototoollibre.desktop"
+ install -Dm644 "desktop/me.ahola.aphototoollibre.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/me.ahola.aphototoollibre.svg"
+ install -Dm644 "desktop/me.ahola.aphototoollibre.metainfo.xml" "$pkgdir/usr/share/metainfo/me.ahola.aphototoollibre.metainfo.xml"
}
+