summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfumseck2017-11-13 15:37:26 +0100
committerfumseck2017-11-13 15:37:26 +0100
commitbbcf770ad2294a4315ea6b8a8bc3804edb793767 (patch)
treee8bedec01c797f63be10eaf17037d33b38b94f55
downloadaur-bbcf770ad2294a4315ea6b8a8bc3804edb793767.tar.gz
add package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD27
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40d1ef7f0ba4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = aphrodite
+ pkgdesc = Manage all server websites from one interface
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/fumseck/aphrodite
+ arch = any
+ license = GPL3
+ depends = php>=7
+ depends = php-apache
+ depends = apache
+ depends = php-pgsql
+ depends = postgresql
+ depends = sqlite
+ depends = mariadb
+ depends = make
+ depends = git
+ depends = composer
+ depends = php-sqlite
+ source = http://git.fumseck.eu/cgit/aphrodite/snapshot/aphrodite-1.0.tar.gz
+ md5sums = 10a9aa2467b2d112a4a83df58f6eca24
+
+pkgname = aphrodite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cc770842670
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Willy Micieli <fumseckworld at gmail dot com>
+# Contributor: Willy Micieli <fumseckworld at gmail dot com>
+
+pkgname=aphrodite
+pkgver=1.0
+pkgrel=1
+pkgdesc="Manage all server websites from one interface"
+arch=('any')
+url="https://github.com/fumseck/aphrodite"
+license=('GPL3')
+depends=('php>=7' 'php-apache' 'apache' 'php-pgsql' 'postgresql' 'sqlite' 'mariadb' 'make' 'git' 'composer' 'php-sqlite' )
+source=(http://git.fumseck.eu/cgit/aphrodite/snapshot/$pkgname-$pkgver.tar.gz)
+md5sums=('10a9aa2467b2d112a4a83df58f6eca24')
+
+build()
+{
+ cd $pkgname-$pkgver
+
+ make
+}
+
+package()
+{
+ cd $srcdir
+ mv $pkgname-$pkgver $pkgname
+ install -d "$pkgname/srv/http/"
+}