summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-04 12:55:06 +0800
committerzxp198210052024-02-04 12:55:06 +0800
commit026343a6a80cd57efe025d6a56971198837fafe5 (patch)
treee8a5a14706ee9c069995bd1fdf443d5c67877a22
parent9f3a6c2491e9d4ac7737a58cea6be5fb8c5f311f (diff)
downloadaur-026343a6a80cd57efe025d6a56971198837fafe5.tar.gz
fix errors
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
-rw-r--r--apifox.sh11
3 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70bc2a6d452d..2b27722a3808 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,27 @@
pkgbase = apifox-bin
pkgdesc = Apifox=Postman+Swagger+Mock+JMeter.API 文档、API 调试、API Mock、API 自动化测试
- pkgver = 2.4.9
+ pkgver = 2.5.3
pkgrel = 1
url = https://apifox.com/
arch = aarch64
arch = x86_64
- license = custom
+ license = LicenseRef-custom
depends = electron22
depends = hicolor-icon-theme
depends = java-runtime
depends = nodejs
depends = lib32-glibc
depends = lib32-gcc-libs
- provides = apifox=2.4.9
+ provides = apifox=2.5.3
conflicts = apifox
+ options = !strip
source = LICENSE.html
source = apifox.sh
sha256sums = 3884df6451dd5aaadc867c2b6882a7feabccb10c7e1df98e48e9fe2414c9fe19
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
- source_aarch64 = apifox-2.4.9-aarch64.zip::https://cdn.apifox.cn/download/Apifox-linux-arm64-deb-latest.zip
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ source_aarch64 = apifox-2.5.3-aarch64.zip::https://cdn.apifox.cn/download/Apifox-linux-arm64-deb-latest.zip
sha256sums_aarch64 = bfedd899ae5776f044af046ea978f851aada1e4082d396e7664569726f6108ee
- source_x86_64 = apifox-2.4.9-x86_64.zip::https://cdn.apifox.cn/download/Apifox-linux-deb-latest.zip
+ source_x86_64 = apifox-2.5.3-x86_64.zip::https://cdn.apifox.cn/download/Apifox-linux-deb-latest.zip
sha256sums_x86_64 = c26d9439b813fc1472c016ab580fdb839ff6b803883cac9fe1751623c975c52a
pkgname = apifox-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2a6ecf4881f4..1a33bf45786f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,17 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=apifox-bin
_pkgname=Apifox
-pkgver=2.4.9
+pkgver=2.5.3
_electronversion=22
pkgrel=1
pkgdesc="Apifox=Postman+Swagger+Mock+JMeter.API 文档、API 调试、API Mock、API 自动化测试"
-arch=('aarch64' 'x86_64')
+arch=(
+ 'aarch64'
+ 'x86_64'
+)
url="https://apifox.com/"
_ghurl="https://github.com/apifox/apifox"
-license=('custom')
+license=('LicenseRef-custom')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=(
@@ -19,6 +22,9 @@ depends=(
'lib32-glibc'
'lib32-gcc-libs'
)
+options=(
+ '!strip'
+)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::https://cdn.apifox.cn/download/${_pkgname}-linux-arm64-deb-latest.zip")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::https://cdn.apifox.cn/download/${_pkgname}-linux-deb-latest.zip")
source=(
@@ -26,15 +32,15 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('3884df6451dd5aaadc867c2b6882a7feabccb10c7e1df98e48e9fe2414c9fe19'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
sha256sums_aarch64=('bfedd899ae5776f044af046ea978f851aada1e4082d396e7664569726f6108ee')
sha256sums_x86_64=('c26d9439b813fc1472c016ab580fdb839ff6b803883cac9fe1751623c975c52a')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/${pkgname%-bin}_${pkgver}_"*.deb
+ bsdtar -xf "${srcdir}/${pkgname%-bin}_"*.deb
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g;s|Utility|Development|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
diff --git a/apifox.sh b/apifox.sh
index c77c53567639..f9ced1432cfc 100644
--- a/apifox.sh
+++ b/apifox.sh
@@ -1,17 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" "$@"
- exit
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file