summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-13 13:07:03 +0800
committerzxp198210052023-12-13 13:07:03 +0800
commit0862f1d0068db7232ce439706ccd9af67a402fa1 (patch)
treed4226f9fc9d466be20d7e051e75a83ca4facb300
parent38393f026dd12708c7d96a22d99190b4cc1f5912 (diff)
downloadaur-0862f1d0068db7232ce439706ccd9af67a402fa1.tar.gz
update to 2.4.3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--apifox.sh17
3 files changed, 36 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fce914b89c0..9f05899ca206 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = apifox-bin
pkgdesc = Apifox=Postman+Swagger+Mock+JMeter.API 文档、API 调试、API Mock、API 自动化测试
- pkgver = 2.3.25
+ pkgver = 2.4.3
pkgrel = 1
url = https://apifox.com/
arch = aarch64
arch = x86_64
license = custom
- depends = bash
depends = electron22
depends = hicolor-icon-theme
depends = java-runtime
@@ -15,15 +14,18 @@ pkgbase = apifox-bin
depends = libdbusmenu-glib
depends = lib32-glibc
depends = gtk2
- provides = apifox=2.3.25
+ depends = libxext
+ depends = libx11
+ depends = dbus-glib
+ provides = apifox=2.4.3
conflicts = apifox
source = LICENSE.html
source = apifox.sh
sha256sums = 3884df6451dd5aaadc867c2b6882a7feabccb10c7e1df98e48e9fe2414c9fe19
- sha256sums = cbf4154e6a26f4099a8da2f3bba63578b0ed9046141ba8bea9c2b4d585dbdf62
- source_aarch64 = apifox-2.3.25-aarch64.zip::https://cdn.apifox.cn/download/Apifox-linux-arm64-latest.zip
+ sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ source_aarch64 = apifox-2.4.3-aarch64.zip::https://cdn.apifox.cn/download/Apifox-linux-arm64-latest.zip
sha256sums_aarch64 = 52701658898f9c9d34998fec0f9e9486e971737e2faa03acd3e93a8d0bdfee0f
- source_x86_64 = apifox-2.3.25-x86_64.zip::https://cdn.apifox.cn/download/Apifox-linux-latest.zip
- sha256sums_x86_64 = 9562bdd272e0b70ff868a80928f70f00e30adaaeedfa876a070e502594d7306d
+ source_x86_64 = apifox-2.4.3-x86_64.zip::https://cdn.apifox.cn/download/Apifox-linux-latest.zip
+ sha256sums_x86_64 = 8836e0ce091ed2e6fbcc9ae0fd75bbe5047f3f084d075793e6e67c5c9ea14ab6
pkgname = apifox-bin
diff --git a/PKGBUILD b/PKGBUILD
index 55d6a76727d9..035b69951904 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=apifox-bin
_pkgname=Apifox
-pkgver=2.3.25
+pkgver=2.4.3
+_electronversion=22
pkgrel=1
pkgdesc="Apifox=Postman+Swagger+Mock+JMeter.API 文档、API 调试、API Mock、API 自动化测试"
arch=('aarch64' 'x86_64')
url="https://apifox.com/"
-_githuburl="https://github.com/apifox/apifox"
+_ghurl="https://github.com/apifox/apifox"
license=('custom')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=(
- 'bash'
- 'electron22'
+ "electron${_electronversion}"
'hicolor-icon-theme'
'java-runtime'
'gdk-pixbuf2'
@@ -20,16 +20,25 @@ depends=(
'libdbusmenu-glib'
'lib32-glibc'
'gtk2'
+ 'libxext'
+ 'libx11'
+ 'dbus-glib'
)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::https://cdn.apifox.cn/download/${_pkgname}-linux-arm64-latest.zip")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::https://cdn.apifox.cn/download/${_pkgname}-linux-latest.zip")
-source=("LICENSE.html"
- "${pkgname%-bin}.sh")
+source=(
+ "LICENSE.html"
+ "${pkgname%-bin}.sh"
+)
sha256sums=('3884df6451dd5aaadc867c2b6882a7feabccb10c7e1df98e48e9fe2414c9fe19'
- 'cbf4154e6a26f4099a8da2f3bba63578b0ed9046141ba8bea9c2b4d585dbdf62')
+ '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
sha256sums_aarch64=('52701658898f9c9d34998fec0f9e9486e971737e2faa03acd3e93a8d0bdfee0f')
-sha256sums_x86_64=('9562bdd272e0b70ff868a80928f70f00e30adaaeedfa876a070e502594d7306d')
+sha256sums_x86_64=('8836e0ce091ed2e6fbcc9ae0fd75bbe5047f3f084d075793e6e67c5c9ea14ab6')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${_pkgname}.AppImage"
"${srcdir}/${_pkgname}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun --no-sandbox %U|${pkgname%-bin} -no-sandbox|g;s|Utility|Development|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
diff --git a/apifox.sh b/apifox.sh
index cecd755871c8..2ec4412e5c4f 100644
--- a/apifox.sh
+++ b/apifox.sh
@@ -1,11 +1,14 @@
#!/bin/bash
-_ELECTRON=/usr/bin/electron22
-APPDIR="/usr/lib/apifox"
-export PATH="${APPDIR}:${PATH}"
-export LD_LIBRARY_PATH="${APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${APPDIR}/app.asar"
+set -e
+_APPDIR="/usr/lib/@appname@"
+export PATH="${_APPDIR}:${PATH}"
+export ELECTRON_IS_DEV=0
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${_APPDIR}/@appasar@"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
else
- exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
fi \ No newline at end of file