summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-06 19:09:01 +0800
committerzxp198210052023-07-06 19:09:01 +0800
commit8897ca5a3823bcbdea098aaed4ab72640ac3ad4b (patch)
tree50670717ff72d08ba58eb800fdec3482e212a4e3
parentbc80fe864a1f809f87f8b9eeb4c1591a8d76192a (diff)
downloadaur-8897ca5a3823bcbdea098aaed4ab72640ac3ad4b.tar.gz
update to 2.3.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6330e30043f..227b4fa4de38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = apifox-bin
pkgdesc = Apifox=Postman+Swagger+Mock+JMeter.API 文档、API 调试、API Mock、API 自动化测试
- pkgver = 2.3.1
+ pkgver = 2.3.2
pkgrel = 1
url = https://apifox.com/
+ arch = aarch64
arch = x86_64
license = custom
depends = gtk3
@@ -35,10 +36,11 @@ pkgbase = apifox-bin
depends = mesa
depends = sh
conflicts = apifox
- conflicts = apifox-appimage
- source = apifox-deb-2.3.1.zip::https://cdn.apifox.cn/download/Apifox-linux-deb-latest.zip
- source = LICENSE.html::https://apifox.com//help/app/faq/
- sha256sums = f43d6577647d2fe660135709098d512fda74a0a18f238597b25b90848751f806
- sha256sums = e0ab26c0ec96a3a0c2e8d89a59200eaeff05b2f7964b4f6f06871e8e5f5e0629
+ source = LICENSE.html::https://apifox.com//help/terms-and-conditions/terms-of-service
+ sha256sums = a88d3dd481d4e7893e1c31be145aa7ab51c7c7d15a86da1f78d7e7d8c5ec4eec
+ source_aarch64 = apifox-2.3.2-aarch64.zip::https://cdn.apifox.cn/download/Apifox-linux-arm64-deb-latest.zip
+ sha256sums_aarch64 = 2be783ab572d6999ec64a3cdfe4cdd85a153e364db3e6be11988eff703d12292
+ source_x86_64 = apifox-2.3.2-x86_64.zip::https://cdn.apifox.cn/download/Apifox-linux-deb-latest.zip
+ sha256sums_x86_64 = 59e5b64a987576ebb7852c6994e69c3a37a43d7991a7a6c19eebe3ebba454bb3
pkgname = apifox-bin
diff --git a/PKGBUILD b/PKGBUILD
index 94347e521535..343e4d5cea5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname="apifox-bin"
-pkgver=2.3.1
+pkgver=2.3.2
pkgrel=1
pkgdesc="Apifox=Postman+Swagger+Mock+JMeter.API 文档、API 调试、API Mock、API 自动化测试"
-arch=('x86_64')
+arch=('aarch64' 'x86_64')
url="https://apifox.com/"
+_githuburl="https://github.com/apifox/apifox"
license=('custom')
-conflicts=("${pkgname%-bin}" "${pkgname%-bin}-appimage")
+conflicts=("${pkgname%-bin}")
providers=("${pkgname%-bin}")
depends=('gtk3' 'lib32-gcc-libs' 'nodejs' 'nss' 'at-spi2-core' 'java-runtime' 'alsa-lib' 'libxdamage' 'expat' 'cairo' 'libx11' 'dbus' \
'nspr' 'libxrandr' 'lib32-glibc' 'libxext' 'gcc-libs' 'libxcomposite' 'libxcb' 'glib2' 'libcups' 'libdrm' 'glibc' 'libxkbcommon' \
'libxfixes' 'hicolor-icon-theme' 'pango' 'mesa' 'sh')
-source=("${pkgname%-bin}-deb-${pkgver}.zip::https://cdn.apifox.cn/download/Apifox-linux-deb-latest.zip"
- "LICENSE.html::${url}/help/app/faq/")
-sha256sums=('f43d6577647d2fe660135709098d512fda74a0a18f238597b25b90848751f806'
- 'e0ab26c0ec96a3a0c2e8d89a59200eaeff05b2f7964b4f6f06871e8e5f5e0629')
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::https://cdn.apifox.cn/download/Apifox-linux-arm64-deb-latest.zip")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::https://cdn.apifox.cn/download/Apifox-linux-deb-latest.zip")
+source=("LICENSE.html::${url}/help/terms-and-conditions/terms-of-service")
+sha256sums=('a88d3dd481d4e7893e1c31be145aa7ab51c7c7d15a86da1f78d7e7d8c5ec4eec')
+sha256sums_aarch64=('2be783ab572d6999ec64a3cdfe4cdd85a153e364db3e6be11988eff703d12292')
+sha256sums_x86_64=('59e5b64a987576ebb7852c6994e69c3a37a43d7991a7a6c19eebe3ebba454bb3')
package() {
ar -x "${pkgname%-bin}_${pkgver}_amd64.deb"