summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2021-08-29 14:15:28 +0800
committeryjun2021-08-29 14:15:28 +0800
commitbe4f671c99a28c0c53cb784c24215d95672209ca (patch)
tree5408abd869e78c63ac1fabeec845f18c84208d0d
parent6bc413aa1949ab7bcd006a4e0a97795b3c6f59a3 (diff)
downloadaur-be4f671c99a28c0c53cb784c24215d95672209ca.tar.gz
fix: wrong path in desktop entry
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95b365a3c4d0..712462bc35ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = apipost-bin
pkgdesc = An API debugging and management tool that supports team collaboration and can generate documents directly.
pkgver = 5.4.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.apipost.cn/
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index 549c68582150..a09c685444a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=apipost-bin
_pkgname=${pkgname%-bin}
pkgver=5.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="An API debugging and management tool that supports team collaboration and can generate documents directly."
arch=('x86_64')
url="https://www.apipost.cn/"
@@ -22,5 +22,8 @@ package() {
install -dm755 ${pkgdir}/usr/bin/
ln -sf /opt/${_pkgname}/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+
+ # desktop entry
+ sed -i "s|/opt/ApiPost|/opt/${_pkgname}|g" ${pkgdir}/usr/share/applications/${_pkgname}.desktop
}
# vim: set sw=2 ts=2 et: