summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAttenuation2019-02-12 15:21:19 +0800
committerAttenuation2019-02-12 15:21:19 +0800
commitb356f4c60d7b1ae4b09786ce54854ad76740af14 (patch)
tree2c3504c1cccf60391d1cfc01cbd0ca991c5e3867
downloadaur-b356f4c60d7b1ae4b09786ce54854ad76740af14.tar.gz
add apk-decompiler
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e40c803b9d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = apk-decompiler
+ pkgdesc = Small Rust utlity to decompile Android apks
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/robertohuertasm/apk-decompiler
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ source = apk-decompiler-0.2.1.tar.gz::https://github.com/robertohuertasm/apk-decompiler/archive/v0.2.1.tar.gz
+ sha256sums = 817cb2e2566745c5437fd09394bdf2fdafbd46bb4e70e16df610b9f022abc67b
+
+pkgname = apk-decompiler
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..827ee1f0d18e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Attenuation <ouyangjun1999@gmail.com>
+pkgname=apk-decompiler
+pkgver=0.2.1
+pkgrel=1
+pkgdesc='Small Rust utlity to decompile Android apks'
+arch=('x86_64')
+url='https://github.com/robertohuertasm/apk-decompiler'
+license=('MIT')
+makedepends=('rust')
+depends=()
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('817cb2e2566745c5437fd09394bdf2fdafbd46bb4e70e16df610b9f022abc67b')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 target/release/$pkgname "$pkgdir/usr/bin/$pkgname"
+}