summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwcyat2023-12-20 22:46:28 +0800
committerwcyat2023-12-20 22:46:28 +0800
commit4d3031c8483ba3b6f27ae1ace6749c16d606c5ac (patch)
tree106f16777bf81a0ec4577a7c59f0ffc09ec5c25c
parent42025097202a88fbd1ab4c2573259ed764d1662f (diff)
downloadaur-4d3031c8483ba3b6f27ae1ace6749c16d606c5ac.tar.gz
fix: add apktool.jar using symbolic link
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce657d9c7de5..a22a8f64ea89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = apk-editor-studio
pkgdesc = Powerful yet easy to use APK editor
pkgver = 1.7.1
- pkgrel = 1
+ pkgrel = 2
url = https://qwertycube.com/apk-editor-studio
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 84fd930c0622..e7e89a7f201b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=apk-editor-studio
pkgver=1.7.1
-pkgrel=1
+pkgrel=2
pkgdesc="Powerful yet easy to use APK editor"
arch=('x86_64')
url='https://qwertycube.com/apk-editor-studio'
@@ -27,14 +27,13 @@ build() {
rm -rf build
mkdir build
cd "${srcdir}/${pkgname}-${pkgver}"
- cmake -B ./build -DCMAKE_BUILD_TYPE=Release -DCMAKE_PREFIX_PATH="/usr/lib/qt"
- cmake --build ./build --config Release
+ cmake -B ./build -DCMAKE_BUILD_TYPE=Release
+ cmake --build ./build
}
package() {
- cd "${pkgname}-${pkgver}"
- install -Dm755 build/bin/apk-editor-studio -t "${pkgdir}/usr/bin/"
- install -Dm644 dist/linux/share/applications/* -t "${pkgdir}/usr/share/applications/"
- cp -r dist/linux/share/icons/ "${pkgdir}/usr/share/"
+ cd "${pkgname}-${pkgver}"
+ cmake --install ./build --prefix="${pkgdir}/usr"
+ ln -s /usr/share/android-apktool/apktool.jar "${pkgdir}/usr/share/apk-editor-studio/tools/"
}
# vim:set ts=2 sw=2 et: