diff options
author | wcyat | 2023-12-20 22:46:28 +0800 |
---|---|---|
committer | wcyat | 2023-12-20 22:46:28 +0800 |
commit | 4d3031c8483ba3b6f27ae1ace6749c16d606c5ac (patch) | |
tree | 106f16777bf81a0ec4577a7c59f0ffc09ec5c25c | |
parent | 42025097202a88fbd1ab4c2573259ed764d1662f (diff) | |
download | aur-4d3031c8483ba3b6f27ae1ace6749c16d606c5ac.tar.gz |
fix: add apktool.jar using symbolic link
-rw-r--r-- | .SRCINFO | 2 | ||||
-rw-r--r-- | PKGBUILD | 13 |
2 files changed, 7 insertions, 8 deletions
@@ -1,7 +1,7 @@ pkgbase = apk-editor-studio pkgdesc = Powerful yet easy to use APK editor pkgver = 1.7.1 - pkgrel = 1 + pkgrel = 2 url = https://qwertycube.com/apk-editor-studio arch = x86_64 license = GPL3 @@ -2,7 +2,7 @@ pkgname=apk-editor-studio pkgver=1.7.1 -pkgrel=1 +pkgrel=2 pkgdesc="Powerful yet easy to use APK editor" arch=('x86_64') url='https://qwertycube.com/apk-editor-studio' @@ -27,14 +27,13 @@ build() { rm -rf build mkdir build cd "${srcdir}/${pkgname}-${pkgver}" - cmake -B ./build -DCMAKE_BUILD_TYPE=Release -DCMAKE_PREFIX_PATH="/usr/lib/qt" - cmake --build ./build --config Release + cmake -B ./build -DCMAKE_BUILD_TYPE=Release + cmake --build ./build } package() { - cd "${pkgname}-${pkgver}" - install -Dm755 build/bin/apk-editor-studio -t "${pkgdir}/usr/bin/" - install -Dm644 dist/linux/share/applications/* -t "${pkgdir}/usr/share/applications/" - cp -r dist/linux/share/icons/ "${pkgdir}/usr/share/" + cd "${pkgname}-${pkgver}" + cmake --install ./build --prefix="${pkgdir}/usr" + ln -s /usr/share/android-apktool/apktool.jar "${pkgdir}/usr/share/apk-editor-studio/tools/" } # vim:set ts=2 sw=2 et: |