summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Bertelli2022-06-24 14:20:54 -0300
committerFilipe Bertelli2022-06-24 14:20:54 -0300
commit058109b9d16eb9c6629cca08db3a083bbb0d7828 (patch)
tree9723f4f096602dfc5c810a3991f3f58aeeb3e565
parent5cdd5ebf9a47ac25967af98413980d8f110a5ff8 (diff)
downloadaur-058109b9d16eb9c6629cca08db3a083bbb0d7828.tar.gz
Updated to 1.6.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD36
2 files changed, 28 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5272fc89be5d..18ac60413f40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apk-editor-studio-bin
pkgdesc = Powerful yet easy to use APK editor
- pkgver = 1.4.0
+ pkgver = 1.6.0
pkgrel = 1
url = https://qwertycube.com/apk-editor-studio
arch = x86_64
@@ -8,13 +8,9 @@ pkgbase = apk-editor-studio-bin
depends = qt5-base
depends = java-runtime>=8
depends = hicolor-icon-theme
- depends = android-sdk-build-tools
- depends = android-sdk-platform-tools
- depends = android-apktool
optdepends = libsecret: Enable password manager backend
provides = apk-editor-studio
- source = apk-editor-studio-bin-1.4.0.deb::https://github.com/kefir500/apk-editor-studio/releases/download/v1.4.0/apk-editor-studio_linux_1.4.0.deb
- sha256sums = 7383abad2a5996e02076173a4cbcbe417fce591531631a682c0aaaa7335d92d2
+ source = https://github.com/kefir500/apk-editor-studio/releases/download/v1.6.0/apk-editor-studio_linux_1.6.0.AppImage
+ sha256sums = 181e3b75d3b31a3d8653700b90101d7897db7544e61c57fb606d2c6083eaf49f
pkgname = apk-editor-studio-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index e8492c041767..62612b01289a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,37 @@
-# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Maintainer: Filipe Bertelli <filipebertelli@tutanota.com>
pkgname=apk-editor-studio-bin
-pkgver=1.4.0
+pkgver=1.6.0
pkgrel=1
pkgdesc="Powerful yet easy to use APK editor"
arch=('x86_64')
provides=("${pkgname%-bin}")
-url='https://qwertycube.com/apk-editor-studio'
+url='https://github.com/kefir500/apk-editor-studio'
license=('GPL3')
depends=('qt5-base'
'java-runtime>=8'
- 'hicolor-icon-theme'
- 'android-sdk-build-tools'
- 'android-sdk-platform-tools'
- 'android-apktool')
+ 'hicolor-icon-theme')
optdepends=('libsecret: Enable password manager backend')
-source=("${pkgname}-${pkgver}.deb::https://github.com/kefir500/apk-editor-studio/releases/download/v${pkgver}/apk-editor-studio_linux_${pkgver}.deb")
-sha256sums=('7383abad2a5996e02076173a4cbcbe417fce591531631a682c0aaaa7335d92d2')
+source=("https://github.com/kefir500/apk-editor-studio/releases/download/v${pkgver}/apk-editor-studio_linux_${pkgver}.AppImage")
+sha256sums=('181e3b75d3b31a3d8653700b90101d7897db7544e61c57fb606d2c6083eaf49f')
+
+prepare() {
+ chmod +x "${pkgname%-bin}_linux_$pkgver.AppImage"
+ ./"${pkgname%-bin}_linux_$pkgver.AppImage" --appimage-extract
+
+ # Remove X-AppImage-Version
+ sed -i '/AppImage/d' "squashfs-root/${pkgname%-bin}.desktop"
+}
package() {
- tar xvf data.tar.xz -C "${pkgdir}/"
-} \ No newline at end of file
+ install -d "$pkgdir/usr/bin"
+ install -Dm755 "squashfs-root/usr/bin/${pkgname%-bin}" -t "$pkgdir/usr/bin/"
+
+ install -Dm644 "squashfs-root/${pkgname%-bin}.desktop" -t "$pkgdir/usr/share/applications/"
+
+ install -d "$pkgdir/usr/share/${pkgname%-bin}"
+ cp -r "squashfs-root/usr/share/${pkgname%-bin}/" "$pkgdir/usr/share/"
+
+ install -d "$pkgdir/usr/share/icons/"
+ cp -r squashfs-root/usr/share/icons/hicolor/ "$pkgdir/usr/share/icons/"
+}