summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-23 10:38:41 +0800
committerzxp198210052024-04-23 10:38:41 +0800
commitbb3f7fc14290334a6df12e3bdc44eced2f131adc (patch)
treea1850b8cf1441dadb53ecb8a9e0596f3e4380ac9
parentf5efbb9dfe4f1424d7f610eebef103624078f8e0 (diff)
downloadaur-bb3f7fc14290334a6df12e3bdc44eced2f131adc.tar.gz
fix errors
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD84
-rw-r--r--apk-editor-studio.sh12
3 files changed, 77 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 629410cf5c17..1cc081cd165b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,25 @@
pkgbase = apk-editor-studio-bin
- pkgdesc = Powerful yet easy to use APK editor
+ pkgdesc = A powerful yet easy to use APK reverse-engineering tool
pkgver = 1.7.1
- pkgrel = 1
- url = https://github.com/kefir500/apk-editor-studio
+ pkgrel = 2
+ url = https://qwertycube.com/apk-editor-studio/
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
+ makedepends = fuse2
depends = qt5-base
depends = java-runtime>=8
- depends = hicolor-icon-theme
depends = android-sdk-build-tools
depends = android-sdk-platform-tools
+ depends = libusb
+ depends = android-apktool
optdepends = libsecret: Enable password manager backend
- provides = apk-editor-studio
- source = https://github.com/kefir500/apk-editor-studio/releases/download/v1.7.1/apk-editor-studio_linux_1.7.1.AppImage
+ provides = apk-editor-studio=1.7.1
+ conflicts = apk-editor-studio
+ options = !strip
+ options = !emptydirs
+ source = apk-editor-studio-1.7.1.AppImage::https://github.com/kefir500/apk-editor-studio/releases/download/v1.7.1/apk-editor-studio_linux_1.7.1.AppImage
+ source = apk-editor-studio.sh
sha256sums = 548cdee09e9951b577c0f2b9818ba90dbedef13ca4d57a7e20eab488c5ab1892
+ sha256sums = 7b0831f35c90ccd21f71c30ba84a5f91371a12302afe6262df6ad7af66bd1e70
pkgname = apk-editor-studio-bin
diff --git a/PKGBUILD b/PKGBUILD
index 24aeb7f62f12..a8f2db18d0b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,58 @@
-# Maintainer: Filipe Bertelli <filipebertelli@tutanota.com>
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+# Contributor: Filipe Bertelli <filipebertelli@tutanota.com>
# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
-
pkgname=apk-editor-studio-bin
+_appname=application-vnd.android.package-archive
pkgver=1.7.1
-pkgrel=1
-pkgdesc="Powerful yet easy to use APK editor"
+pkgrel=2
+pkgdesc="A powerful yet easy to use APK reverse-engineering tool"
arch=('x86_64')
provides=("${pkgname%-bin}")
-url='https://github.com/kefir500/apk-editor-studio'
-license=('GPL3')
-depends=('qt5-base'
- 'java-runtime>=8'
- 'hicolor-icon-theme'
- 'android-sdk-build-tools'
- 'android-sdk-platform-tools')
-optdepends=('libsecret: Enable password manager backend')
-source=("https://github.com/kefir500/apk-editor-studio/releases/download/v${pkgver}/apk-editor-studio_linux_${pkgver}.AppImage")
-sha256sums=('548cdee09e9951b577c0f2b9818ba90dbedef13ca4d57a7e20eab488c5ab1892')
-
-prepare() {
- chmod +x "${pkgname%-bin}_linux_$pkgver.AppImage"
- ./"${pkgname%-bin}_linux_$pkgver.AppImage" --appimage-extract
-
- # Remove X-AppImage-Version
- sed -i '/AppImage/d' "squashfs-root/${pkgname%-bin}.desktop"
+url="https://qwertycube.com/apk-editor-studio/"
+_ghurl='https://github.com/kefir500/apk-editor-studio'
+license=('GPL-3.0-only')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ 'qt5-base'
+ 'java-runtime>=8'
+ 'android-sdk-build-tools'
+ 'android-sdk-platform-tools'
+ 'libusb'
+ 'android-apktool'
+)
+makedepends=(
+ 'fuse2'
+)
+optdepends=(
+ 'libsecret: Enable password manager backend'
+)
+options=(
+ '!strip'
+ '!emptydirs'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_linux_${pkgver}.AppImage"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('548cdee09e9951b577c0f2b9818ba90dbedef13ca4d57a7e20eab488c5ab1892'
+ '7b0831f35c90ccd21f71c30ba84a5f91371a12302afe6262df6ad7af66bd1e70')
+build() {
+ sed -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@runname@|${pkgname%-bin}|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
}
-
package() {
- install -d "$pkgdir/usr/bin"
- install -Dm755 "squashfs-root/usr/bin/${pkgname%-bin}" -t "$pkgdir/usr/bin/"
-
- install -Dm644 "squashfs-root/${pkgname%-bin}.desktop" -t "$pkgdir/usr/share/applications/"
-
- install -d "$pkgdir/usr/share/${pkgname%-bin}"
- cp -r "squashfs-root/usr/share/${pkgname%-bin}/" "$pkgdir/usr/share/"
-
- install -d "$pkgdir/usr/share/icons/"
- cp -r squashfs-root/usr/share/icons/hicolor/ "$pkgdir/usr/share/icons/"
-}
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm755 -d "${pkgdir}/opt/${pkgname%-bin}"
+ cp -r "${srcdir}/squashfs-root/usr/"{bin,lib,plugins} "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ for _icons in 16x16 24x24 32x32 48x48 64x64 128x128 256x256 512x512;do
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/mimetypes/${_appname}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/mimetypes"
+ done
+} \ No newline at end of file
diff --git a/apk-editor-studio.sh b/apk-editor-studio.sh
new file mode 100644
index 000000000000..a5713ebc8888
--- /dev/null
+++ b/apk-editor-studio.sh
@@ -0,0 +1,12 @@
+#!/bin/bash
+set -e
+_APPDIR="/opt/@appname@"
+_RUNNAME="${_APPDIR}/bin/@runname@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export QT_PLUGIN_PATH="${_APPDIR}/plugins:${QT_PLUGIN_PATH}"
+export QML_IMPORT_PATH="${_APPDIR}/qml:${QML_IMPORT_PATH}"
+export QML2_IMPORT_PATH="${_APPDIR}/qml:${QML2_IMPORT_PATH}"
+export QT_QPA_PLATFORMTHEME="gtk2"
+cd "${_APPDIR}"
+exec "${_RUNNAME}" "$@" || exit $? \ No newline at end of file