summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortheguy2021-03-25 18:29:32 +0100
committertheguy2021-03-25 18:29:32 +0100
commit9ed32e80ac672b67aea939300bc4dfc952c0cbef (patch)
tree780fbc932529a0f5156aa892a41261d810cc41b7
downloadaur-9ed32e80ac672b67aea939300bc4dfc952c0cbef.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79f662805508
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = apkleaks-git
+ pkgdesc = scanning apk file for URIs, endpoints & secrets. (git version)
+ pkgver = v1.0.2.r103.g401e09c
+ pkgrel = 1
+ url = https://github.com/dwisiswant0/apkleaks
+ arch = any
+ license = Apache2
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pyaxmlparser
+ conflicts = apkleaks
+ source = apkleaks-git::git+https://github.com/dwisiswant0/apkleaks.git
+ sha256sums = SKIP
+
+pkgname = apkleaks-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7108d61a3efc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: theguy147 <yakamoz147 (at) protonmail (dot) com>
+
+pkgname=apkleaks-git
+pkgver=v1.0.2.r103.g401e09c
+pkgrel=1
+pkgdesc="scanning apk file for URIs, endpoints & secrets. (git version)"
+url="https://github.com/dwisiswant0/apkleaks"
+depends=('python' 'python-pyaxmlparser')
+makedepends=('python-setuptools')
+license=('Apache2')
+conflicts=('apkleaks')
+arch=('any')
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}