summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuc Ritchie2018-04-18 09:46:39 -0400
committerLuc Ritchie2018-04-18 09:48:12 -0400
commit4f18ee9cb7cc769a42ec88fde6dc25fc41d4bd65 (patch)
tree9b09b658a3bd12e3658051f738d90c6af457e963
parent0d1b1807225106067d74dfbd8804b8cf8bdd3f7f (diff)
downloadaur-4f18ee9cb7cc769a42ec88fde6dc25fc41d4bd65.tar.gz
Stop being opinionated about upstream post-install setup
It now requires tools that aren't available as dependencies anyway
-rw-r--r--.SRCINFO11
-rw-r--r--APKTOOL_VERSION8
-rw-r--r--PKGBUILD21
-rwxr-xr-xapkstudio-setup.sh12
-rw-r--r--change-vendor-zip-warning.patch11
5 files changed, 6 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4be7f47c2e3b..0ba7523eec1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Apr 8 10:05:14 UTC 2016
+# Wed Apr 18 13:39:51 UTC 2018
pkgbase = apkstudio-git
pkgdesc = An IDE for decompiling/editing & then recompiling of android application binaries.
- pkgver = r100.9e114ca
+ pkgver = r211.5b6f115
pkgrel = 1
epoch = 1
url = http://www.vaibhavpandey.com/apkstudio/
@@ -14,15 +14,8 @@ pkgbase = apkstudio-git
makedepends = unzip
depends = qt5-base
depends = android-tools
- depends = android-apktool
source = git+https://github.com/vaibhavpandeyvpz/apkstudio.git
- source = APKTOOL_VERSION
- source = apkstudio-setup.sh
- source = change-vendor-zip-warning.patch
sha256sums = SKIP
- sha256sums = ff6ea79b60edfc59c6556ba1f349aae9da3cbb99d5d35239521ebb8f3a201a8c
- sha256sums = f750ecf7d4ddf14922aa52e98ec37f6277692bd88f934f4a3a41b0e888017a1d
- sha256sums = addf387dfb760341e694c9fe50900b7e39acd71f4ff7e3b793ae9347c2b9c0ab
pkgname = apkstudio-git
diff --git a/APKTOOL_VERSION b/APKTOOL_VERSION
deleted file mode 100644
index 9b89dec7ed19..000000000000
--- a/APKTOOL_VERSION
+++ /dev/null
@@ -1,8 +0,0 @@
-{
- "apktool": {
- "commit": "180728d6b8def11cb84280be7a242ed13e5422a3",
- "tag": "2.1.0",
- "url": "https://ibotpeaches.github.io/Apktool/"
- }
-}
-
diff --git a/PKGBUILD b/PKGBUILD
index 6ad3b7abbf82..a57c627e1de7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,23 @@
_pkgname=apkstudio
pkgname=$_pkgname-git
-pkgver=r100.9e114ca
+pkgver=r211.5b6f115
pkgrel=1
epoch=1
pkgdesc='An IDE for decompiling/editing & then recompiling of android application binaries.'
arch=('i686' 'x86_64')
url='http://www.vaibhavpandey.com/apkstudio/'
license=('GPL2')
-depends=('qt5-base' 'android-tools' 'android-apktool')
+depends=('qt5-base' 'android-tools')
makedepends=('git' 'qt5-tools' 'unzip')
-source=('git+https://github.com/vaibhavpandeyvpz/apkstudio.git'
- 'APKTOOL_VERSION'
- 'apkstudio-setup.sh'
- 'change-vendor-zip-warning.patch')
-sha256sums=('SKIP'
- 'ff6ea79b60edfc59c6556ba1f349aae9da3cbb99d5d35239521ebb8f3a201a8c'
- 'f750ecf7d4ddf14922aa52e98ec37f6277692bd88f934f4a3a41b0e888017a1d'
- 'addf387dfb760341e694c9fe50900b7e39acd71f4ff7e3b793ae9347c2b9c0ab')
+source=('git+https://github.com/vaibhavpandeyvpz/apkstudio.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$srcdir/$_pkgname"
- patch -p0 -i ../change-vendor-zip-warning.patch
-}
-
build() {
cd "$srcdir/$_pkgname"
lrelease-qt5 res/lang/en.ts
@@ -41,6 +30,4 @@ build() {
package() {
cd "$srcdir"
install -Dm755 "$_pkgname/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
- install -Dm744 'APKTOOL_VERSION' "$pkgdir/usr/share/$pkgname/APKTOOL_VERSION"
- install -Dm755 'apkstudio-setup.sh' "$pkgdir/usr/bin/apkstudio-setup.sh"
}
diff --git a/apkstudio-setup.sh b/apkstudio-setup.sh
deleted file mode 100755
index adc640667de9..000000000000
--- a/apkstudio-setup.sh
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/bash
-set -eu
-echo APK Studio normally requires you to download \"vendor.zip\" and extract it.
-echo It contains apktool.jar. Since that\'s a dependency of this package, this
-echo script will instead create symbolic links in $HOME/.apkstudio/vendor/.
-echo
-
-mkdir -p "$HOME/.apkstudio/vendor/"
-[ -e "$HOME/.apkstudio/vendor/apktool.jar" ] || ln -s "/usr/share/android-apktool/apktool.jar" "$HOME/.apkstudio/vendor/apktool.jar"
-[ -e "$HOME/.apkstudio/vendor/VERSION" ] || ln -s "/usr/share/apkstudio-git/APKTOOL_VERSION" "$HOME/.apkstudio/vendor/VERSION"
-
-echo You may now use APK Studio. Have a nice day!
diff --git a/change-vendor-zip-warning.patch b/change-vendor-zip-warning.patch
deleted file mode 100644
index ce385cb217fd..000000000000
--- a/change-vendor-zip-warning.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- res/lang/en.ts 2016-04-08 05:33:01.927645775 -0400
-+++ res/lang/en.ts.new 2016-04-08 05:38:46.388668962 -0400
-@@ -319,7 +319,7 @@
- </message>
- <message>
- <source>download_vendor</source>
-- <translation><![CDATA[You need to download some 3rd-party applications/files from <a href="%1">here</a> and place them in <strong>%2</strong> for APK Studio to work.]]></translation>
-+ <translation><![CDATA[You need to run apkstudio-setup.sh first for APK Studio to work.]]></translation>
- </message>
- <message>
- <source>decode_failure</source>