summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuc Ritchie2015-10-13 12:16:27 -0400
committerLuc Ritchie2015-10-14 04:32:53 -0400
commit6487e16713cebe90b5bec5f086ea4d658dce10ae (patch)
tree435b141d595ddb50361b912a592e74840a077048
parentaedb7fde08f9ab58ae74359fb598846468cc5bf0 (diff)
downloadaur-6487e16713cebe90b5bec5f086ea4d658dce10ae.tar.gz
Update to 3.0.0.b4 and new repo location
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7faf2b7ef884..d61d95db79b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = apkstudio-git
pkgdesc = An IDE for decompiling/editing & then recompiling of android application binaries.
- pkgver = r2.b1e443a
+ pkgver = 3.0.0.b4.r0.g8a6fefd
pkgrel = 1
- url = http://apkstudio.codeplex.com/
+ url = http://github.vaibhavpandey.com/apkstudio/
arch = i686
arch = x86_64
license = GPL2
makedepends = git
+ makedepends = qt5-tools
depends = qt5-base
- source = git+https://git01.codeplex.com/apkstudio.git
+ source = git+https://github.com/vaibhavpandeyvpz/apkstudio.git
sha256sums = SKIP
pkgname = apkstudio-git
diff --git a/PKGBUILD b/PKGBUILD
index c609e1f371d7..888acdeec0de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,34 @@
_pkgname=apkstudio
pkgname=$_pkgname-git
-pkgver=r2.b1e443a
+pkgver=3.0.0.b4.r0.g8a6fefd
pkgrel=1
pkgdesc='An IDE for decompiling/editing & then recompiling of android application binaries.'
arch=('i686' 'x86_64')
-url='http://apkstudio.codeplex.com/'
+url='http://github.vaibhavpandey.com/apkstudio/'
license=('GPL2')
depends=('qt5-base')
-makedepends=('git')
-source=('git+https://git01.codeplex.com/apkstudio.git')
+makedepends=('git' 'qt5-tools')
+source=('git+https://github.com/vaibhavpandeyvpz/apkstudio.git')
sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "$srcdir/$_pkgname"
+ lrelease-qt5 res/lang/en.ts
mkdir build
cd build
- qmake-qt5 -r ../apkstudio.pro
+ qmake-qt5 -r ../apkstudio.pro CONFIG+=release
make
}
package() {
cd "$srcdir/$_pkgname"
install -Dm755 "build/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -dm755 "$pkgdir/usr/share/apkstudio/vendor"
+ unzip "external/vendor.zip" -d "$pkgdir/usr/share/apkstudio/vendor"
}