summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuc Ritchie2015-07-10 02:11:14 -0400
committerLuc Ritchie2015-07-10 05:20:40 -0400
commitaedb7fde08f9ab58ae74359fb598846468cc5bf0 (patch)
tree80288abf5330c4641d05f8ccd806a6ab46f7d389
downloadaur-aedb7fde08f9ab58ae74359fb598846468cc5bf0.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7faf2b7ef884
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = apkstudio-git
+ pkgdesc = An IDE for decompiling/editing & then recompiling of android application binaries.
+ pkgver = r2.b1e443a
+ pkgrel = 1
+ url = http://apkstudio.codeplex.com/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = qt5-base
+ source = git+https://git01.codeplex.com/apkstudio.git
+ sha256sums = SKIP
+
+pkgname = apkstudio-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..21d5fc0d09d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+pkg
+src
+apkstudio
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c609e1f371d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: William Luc Ritchie <luc dot ritchie at gmail dot com>
+# Contributor: Borja Ruiz <borja [at] libcrack [dot] so>
+
+_pkgname=apkstudio
+pkgname=$_pkgname-git
+pkgver=r2.b1e443a
+pkgrel=1
+pkgdesc='An IDE for decompiling/editing & then recompiling of android application binaries.'
+arch=('i686' 'x86_64')
+url='http://apkstudio.codeplex.com/'
+license=('GPL2')
+depends=('qt5-base')
+makedepends=('git')
+source=('git+https://git01.codeplex.com/apkstudio.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ mkdir build
+ cd build
+ qmake-qt5 -r ../apkstudio.pro
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 "build/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+}