summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuc Ritchie2015-11-04 15:03:48 -0500
committerLuc Ritchie2015-11-04 16:23:10 -0500
commitd6678c50b93e8a28832850fb331120b856b026a7 (patch)
treeec9109c69de3fce6de4dfeb5bac9d44246a1753a
parent6487e16713cebe90b5bec5f086ea4d658dce10ae (diff)
downloadaur-d6678c50b93e8a28832850fb331120b856b026a7.tar.gz
vendor.zip is no longer in the repo; grab from bintray
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
3 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d61d95db79b8..bc6b8e668e5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apkstudio-git
pkgdesc = An IDE for decompiling/editing & then recompiling of android application binaries.
- pkgver = 3.0.0.b4.r0.g8a6fefd
+ pkgver = 3.0.0.b2.r33.gbab0183
pkgrel = 1
url = http://github.vaibhavpandey.com/apkstudio/
arch = i686
@@ -8,9 +8,13 @@ pkgbase = apkstudio-git
license = GPL2
makedepends = git
makedepends = qt5-tools
+ makedepends = unzip
depends = qt5-base
+ noextract = vendor.zip
source = git+https://github.com/vaibhavpandeyvpz/apkstudio.git
+ source = https://bintray.com/artifact/download/vaibhavpandeyvpz/generic/2015.10.29/vendor.zip
sha256sums = SKIP
+ sha256sums = b089427ee80aff65e87cb19ca2f08cd74d156a1b692da86a1ba37aa39689f539
pkgname = apkstudio-git
diff --git a/.gitignore b/.gitignore
index 21d5fc0d09d4..21c960964801 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
pkg
src
apkstudio
+vendor.zip
diff --git a/PKGBUILD b/PKGBUILD
index 888acdeec0de..48962c5dc766 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,19 @@
_pkgname=apkstudio
pkgname=$_pkgname-git
-pkgver=3.0.0.b4.r0.g8a6fefd
+pkgver=3.0.0.b2.r33.gbab0183
pkgrel=1
pkgdesc='An IDE for decompiling/editing & then recompiling of android application binaries.'
arch=('i686' 'x86_64')
url='http://github.vaibhavpandey.com/apkstudio/'
license=('GPL2')
depends=('qt5-base')
-makedepends=('git' 'qt5-tools')
-source=('git+https://github.com/vaibhavpandeyvpz/apkstudio.git')
-sha256sums=('SKIP')
+makedepends=('git' 'qt5-tools' 'unzip')
+source=('git+https://github.com/vaibhavpandeyvpz/apkstudio.git'
+'https://bintray.com/artifact/download/vaibhavpandeyvpz/generic/2015.10.29/vendor.zip')
+sha256sums=('SKIP'
+ 'b089427ee80aff65e87cb19ca2f08cd74d156a1b692da86a1ba37aa39689f539')
+noextract=('vendor.zip')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -29,8 +32,8 @@ build() {
}
package() {
- cd "$srcdir/$_pkgname"
- install -Dm755 "build/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ cd "$srcdir"
+ install -Dm755 "$_pkgname/build/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
install -dm755 "$pkgdir/usr/share/apkstudio/vendor"
- unzip "external/vendor.zip" -d "$pkgdir/usr/share/apkstudio/vendor"
+ unzip "vendor.zip" -d "$pkgdir/usr/share/apkstudio/vendor"
}