summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen2018-12-29 00:57:39 +0100
committerBen2018-12-29 00:57:39 +0100
commit5c691f679e11a47af86748b2a7a3b98692ce6512 (patch)
tree53be23f8d555fb37a140e8ed3dacfa1238b61ecc
downloadaur-5c691f679e11a47af86748b2a7a3b98692ce6512.tar.gz
Create package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD18
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0ea7da081b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = apm_planner-bin
+ pkgdesc = Ground Control Station for MAVlink based autopilots (e.g. Ardupilot) (binary version)
+ pkgver = 2.0.26
+ pkgrel = 1
+ url = http://ardupilot.org/planner2/
+ arch = x86_64
+ groups = base-devel
+ license = GPL3
+ depends = qt5-base
+ depends = qt5-serialport
+ depends = qt5-svg
+ depends = qt5-script
+ depends = qt5-declarative
+ depends = sdl2
+ depends = flite1
+ depends = libsndfile
+ depends = python
+ depends = python-pexpect
+ source = http://firmware.ardupilot.org/Tools/APMPlanner/apm_planner_2.0.26_xenial64.deb
+ md5sums = 0343dbd67c1c0c5ad5ae557922684912
+
+pkgname = apm_planner-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0a40442a4ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Ben <ben@ported.pw>
+
+pkgname=apm_planner-bin
+pkgver=2.0.26
+pkgrel=1
+pkgdesc="Ground Control Station for MAVlink based autopilots (e.g. Ardupilot) (binary version)"
+arch=('x86_64')
+url="http://ardupilot.org/planner2/"
+license=('GPL3')
+groups=('base-devel')
+depends=('qt5-base' 'qt5-serialport' 'qt5-svg' 'qt5-script' 'qt5-declarative' 'sdl2' 'flite1' 'libsndfile' 'python' 'python-pexpect')
+source=("http://firmware.ardupilot.org/Tools/APMPlanner/apm_planner_${pkgver}_xenial64.deb")
+md5sums=('0343dbd67c1c0c5ad5ae557922684912')
+
+package() {
+ msg2 "Extracting the data.tar.xz..."
+ bsdtar -xf data.tar.xz -C "$pkgdir/"
+}