summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkedap2021-05-14 18:58:12 -0500
committerkedap2021-05-14 18:58:12 -0500
commit20898482a2cd51d6f9914e2734db3023aca7ae0d (patch)
tree12fe0ac7f0ce5d0b014ebd5b4e80f90579dec147
downloadaur-20898482a2cd51d6f9914e2734db3023aca7ae0d.tar.gz
La rama develop
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d1c8e3069cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = apmpkg-git-dev
+ pkgdesc = Un administrador de paquetes universal para linux como modelo: PKGBUILD de la rama develop
+ pkgver = 61.4727c20
+ pkgrel = 1
+ url = https://github.com/Kedap/apmpkg
+ arch = x86_64
+ license = Apache
+ makedepends = cargo
+ depends = git
+ depends = python-pip
+ depends = python2-pip
+ depends = curl
+ depends = fakeroot
+ depends = ruby-bundler
+ depends = rsync
+ conflicts = apmpkg-git
+ source = git+https://github.com/kedap/apmpkg
+ sha256sums = SKIP
+
+pkgname = apmpkg-git-dev
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a83be34fd62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: kedap <dxhqezk@hi2.in>
+
+pkgname=apmpkg-git-dev
+_pkgname=apmpkg
+pkgver=61.4727c20
+pkgrel=1
+pkgdesc="Un administrador de paquetes universal para linux como modelo: PKGBUILD de la rama develop"
+arch=('x86_64')
+url="https://github.com/Kedap/apmpkg"
+license=('Apache')
+depends=('git' 'python-pip' 'python2-pip' 'curl' 'fakeroot' 'ruby-bundler' 'rsync')
+makedepends=('cargo')
+conflicts=('apmpkg-git')
+source=("git+https://github.com/kedap/${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver(){
+ cd "$_pkgname"
+ git checkout -b develop
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_pkgname"
+ cargo build --release --locked
+}
+
+check() {
+ cd "$_pkgname"
+ cargo test --release --locked
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm 755 "target/release/${pkgname}" -t "${pkgdir}/usr/bin"
+ mkdir -p ${pkgdir}/etc/apmpkg/iiabc
+ cp -r src/iiabc/ ${pkgdir}/etc/apmpkg/
+ mkdir -p ${pkgdir}/etc/apmpkg/paquetes
+ install -Dm 644 "${pkgname}.1" -t ${pkgdir}/usr/share/man/man1
+}