summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2021-06-10 14:18:02 +0200
committerhaawda2021-06-10 14:18:02 +0200
commit2289e8770f6bd3e5f26f347cc716f1a7080d2eae (patch)
tree05ef562bb5480b99efe414d75240e0a9f67f7d04
parent0caf7f3402b4a01bb53257313aa64d9f6b14c6b9 (diff)
downloadaur-2289e8770f6bd3e5f26f347cc716f1a7080d2eae.tar.gz
pull from git to fix boost namespace error
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7fd38d5625b..470823e6bdf3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = apngasm
pkgdesc = tool for assembling apng files
pkgver = 3.1.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/apngasm/apngasm
arch = i686
arch = x86_64
license = LGPL
makedepends = cmake
makedepends = boost
+ makedepends = git
depends = libpng
depends = boost-libs
conflicts = apng-utils
- source = apngasm-3.1.6.tar.gz::https://github.com/apngasm/apngasm/archive/3.1.6.tar.gz
- sha512sums = cbc6f0ad119a7ce17079be3434e516265bea619ecb46fe147d652bbaff4652a858698df07a072f5095894961137fe32546f75ad603c7483476be7ffe463cf999
+ source = git+https://github.com/apngasm/apngasm.git#commit=de1c87cd7696384be3235eb07766766891474e09
+ sha512sums = SKIP
pkgname = apngasm
-
diff --git a/PKGBUILD b/PKGBUILD
index 22951fa9e7d0..cb2511bab95d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,19 @@
pkgname=apngasm
pkgver=3.1.6
-pkgrel=1
+pkgrel=2
pkgdesc="tool for assembling apng files"
arch=('i686' 'x86_64')
url="https://github.com/apngasm/apngasm"
license=('LGPL')
conflicts=('apng-utils')
depends=('libpng' 'boost-libs')
-makedepends=('cmake' 'boost')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/${pkgver}.tar.gz")
-sha512sums=('cbc6f0ad119a7ce17079be3434e516265bea619ecb46fe147d652bbaff4652a858698df07a072f5095894961137fe32546f75ad603c7483476be7ffe463cf999')
+makedepends=('cmake' 'boost' 'git')
+source=("git+$url.git#commit=de1c87cd7696384be3235eb07766766891474e09")
+sha512sums=('SKIP')
build() {
- cd $pkgname-${pkgver}
+ cd $pkgname
[[ -d build ]] || mkdir build
cd build
cmake -D CMAKE_INSTALL_PREFIX="/usr" ../
@@ -26,7 +26,7 @@ build() {
}
package() {
- cd $pkgname-${pkgver}/build
+ cd $pkgname/build
make DESTDIR="${pkgdir}" install
install -Dm644 "${pkgdir}"/usr/man/man1/apngasm.1 "${pkgdir}"/usr/share/man/man1/apngasm.1
rm -r "${pkgdir}"/usr/man