summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-03-10 09:33:06 -0600
committerLuis Martinez2022-03-10 09:33:41 -0600
commit1b0ae655c66581d9381de7949ed8f74f2186dcb7 (patch)
treea62c92ab4a61c3d3b896de93e7b2d0702de2a4f9
parentf0be761abff53154ae3e0426c782e7ed9112bb39 (diff)
downloadaur-1b0ae655c66581d9381de7949ed8f74f2186dcb7.tar.gz
update to 0.4.4
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG.md22
-rw-r--r--PKGBUILD4
3 files changed, 27 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba2dc8bc202d..917777bd767e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apollo-rover
pkgdesc = CLI for Apollo's suite of GraphQL developer productivity tools
- pkgver = 0.4.3
+ pkgver = 0.4.4
pkgrel = 1
url = https://github.com/apollographql/rover
changelog = CHANGELOG.md
@@ -10,8 +10,8 @@ pkgbase = apollo-rover
depends = gcc-libs
depends = zlib
options = !lto
- source = apollo-rover-0.4.3.tar.gz::https://github.com/apollographql/rover/archive/v0.4.3.tar.gz
- sha256sums = d91ba41397563ddaae02f93bae0602e9adc1686c681d1cef91742dac71b005f4
+ source = apollo-rover-0.4.4.tar.gz::https://github.com/apollographql/rover/archive/v0.4.4.tar.gz
+ sha256sums = ca8f7ef20ae3022b254c5df15651a81b7643ce6cdb59c6711f3b956ff3f3de47
pkgname = apollo-rover
optdepends = apollo-rover-fed2: experimental Federation v2 support
@@ -21,4 +21,4 @@ pkgname = apollo-rover-fed2
license = custom:EL2
depends = gcc-libs
depends = zlib
- depends = apollo-rover=0.4.3
+ depends = apollo-rover=0.4.4
diff --git a/CHANGELOG.md b/CHANGELOG.md
index cc8f1b065ca6..7afdd2c614e8 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -18,6 +18,26 @@ This project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.htm
## 📚 Documentation -->
+# [0.4.4] - 2022-03-09
+
+## 🛠 Maintenance
+
+- **Updates the version of the underlying composition packages - @EverlastingBugstopper, #1025**
+
+ `rover supergraph compose` now uses `harmonizer@v0.35.3`/`@apollo/federation@v0.35.4` and `rover fed2 supergraph compose` now uses `harmonizer@v2.0.0-preview.2`/`@apollo/composition@v2.0.0-preview.2`.
+
+- **Updates README badges - @EverlastingBugstopper, #1016**
+
+ Replaced the `stability: experimental` badge with a badge showing Rover's total download count, and replaced the outdated GitHub workflow badge with the appropriate CircleCI badge.
+
+# [0.4.3] - 2022-02-14
+
+## 🐛 Fixes
+
+- **Fix npm installer logic for detecting glibc compatibility - @EverlastingBugstopper, #1006 fixes #1004**
+
+ Our npm installer had a dependency that updated to v2.0 which included some breaking changes. These changes made our npm installer always return false when checking if the operating system has an appropriate version of `glibc` installed (in order to download the version of Rover with `supergraph compose` functionality). We have now moved to the appropriate API and installs of v0.4.3 should work as expected.
+
# [0.4.2] - 2022-02-11
## 🚀 Features
@@ -44,7 +64,7 @@ This project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.htm
Migrate away from the `println` and `eprintln` macros that can cause panics from time to time and instead use calm_io to gracefully handle output.
-- **Lowers the maximum required `glibc` version from 2.18 to 2.17 - @EverlastingBugstopper, #990 fixes #992**
+- **Lowers the maximum required `glibc` version from 2.18 to 2.17 - @EverlastingBugstopper, #990 fixes #991**
We build Rover in Docker with the `centos:7` base image, which has `glibc` `v2.17` installed. This means we can lower our installer requirements to 2.17, allowing folks on older machines like centos to install Rover. Thanks to @theJC for the report and help with testing!
diff --git a/PKGBUILD b/PKGBUILD
index 609a8da36ec5..22f8b5bdf8d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=('apollo-rover' 'apollo-rover-fed2')
-pkgver=0.4.3
+pkgver=0.4.4
pkgrel=1
pkgdesc="CLI for Apollo's suite of GraphQL developer productivity tools"
arch=('x86_64')
@@ -12,7 +12,7 @@ makedepends=('cargo')
options=('!lto')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('d91ba41397563ddaae02f93bae0602e9adc1686c681d1cef91742dac71b005f4')
+sha256sums=('ca8f7ef20ae3022b254c5df15651a81b7643ce6cdb59c6711f3b956ff3f3de47')
prepare() {
cd "rover-$pkgver"