summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-02-26 21:18:40 -0600
committerLuis Martinez2023-02-26 21:19:18 -0600
commit6455d2145f337a923f66995da16f830a195913d9 (patch)
tree9fed4290693b4a14c003fbd0cbe7901ad39ab5f8
parent9369db583107f00fbd6f0bb3f14840b43773d2eb (diff)
downloadaur-6455d2145f337a923f66995da16f830a195913d9.tar.gz
update to 0.12.2
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md21
-rw-r--r--PKGBUILD15
3 files changed, 32 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 706e1f4d5b37..feb24402cf3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apollo-rover
pkgdesc = CLI for Apollo's suite of GraphQL developer productivity tools
- pkgver = 0.12.1
+ pkgver = 0.12.2
pkgrel = 1
url = https://github.com/apollographql/rover
install = rover.install
@@ -12,7 +12,7 @@ pkgbase = apollo-rover
depends = zlib
replaces = apollo-rover-fed2
options = !lto
- source = apollo-rover-0.12.1.tar.gz::https://github.com/apollographql/rover/archive/v0.12.1.tar.gz
- sha256sums = f2cbfbc80360903d734ee9f8e513465ee91d08cb4671924521978bd20138e10c
+ source = apollo-rover-0.12.2.tar.gz::https://github.com/apollographql/rover/archive/v0.12.2.tar.gz
+ sha256sums = bbb04e68a8772f46daae1b19840640026f1ba8d7202557b15a90b10259ec3090
pkgname = apollo-rover
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 903afbfc0e3e..61be4fa31669 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -16,6 +16,27 @@ This project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.htm
## 📚 Documentation -->
+# [0.12.2] - 2023-02-23
+
+## 🚀 Features
+
+- **Warn when `federation_version` is not pinned - @EverlastingBugstopper, #1524**
+
+ As of this release, we no longer recommend auto-updates for the `rover supergraph compose` command because of the coordination path that is required to roll out new versions of Federation. If you do not specify an exact `federation_version`, a warning will be printed. In a future version of Rover we will entirely deprecate auto-updating, so please migrate now. This change includes some changes to our documentation as well, check out [the docs](https://www.apollographql.com/docs/rover/commands/supergraphs/#setting-a-composition-version) for more information.
+
+## 🐛 Fixes
+
+- **Fixes composition error reporting in `rover subgraph check` - @EverlastingBugstopper, #1525**
+
+ In Rover v0.12.0 and v0.12.1, running a `rover subgraph check` with an invalid schema failed to report the composition errors, this behavior is fixed in v0.12.2.
+
+## 🛠 Maintenance
+
+- **Updates internal node dependencies - @EverlastingBugstoppe**
+
+ `node` v18.14.0 -> v18.14.1
+ `npm` v9.4.2 -> v9.5.0
+
# [0.12.1] - 2023-02-17
## 🐛 Fixes
diff --git a/PKGBUILD b/PKGBUILD
index 380f186ad61c..a58922ff1304 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=apollo-rover
-pkgver=0.12.1
+_pkg=rover
+pkgver=0.12.2
pkgrel=1
pkgdesc="CLI for Apollo's suite of GraphQL developer productivity tools"
arch=('x86_64')
@@ -14,10 +15,10 @@ options=('!lto')
install=rover.install
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('f2cbfbc80360903d734ee9f8e513465ee91d08cb4671924521978bd20138e10c')
+sha256sums=('bbb04e68a8772f46daae1b19840640026f1ba8d7202557b15a90b10259ec3090')
prepare() {
- cd "rover-$pkgver"
+ cd "$_pkg-$pkgver"
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
@@ -25,19 +26,19 @@ build() {
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
- cd "rover-$pkgver"
+ cd "$_pkg-$pkgver"
cargo build --frozen --release --all-features
}
check() {
export RUSTUP_TOOLCHAIN=stable
- cd "rover-$pkgver"
+ cd "$_pkg-$pkgver"
cargo test --frozen --all-features
}
package() {
- cd "rover-$pkgver"
- install -Dv "target/release/rover" -t "$pkgdir/usr/bin/"
+ cd "$_pkg-$pkgver"
+ install -Dv "target/release/$_pkg" -t "$pkgdir/usr/bin/"
install -Dvm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dvm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}