summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-03-12 20:41:54 -0500
committerLuis Martinez2023-03-12 20:45:09 -0500
commit99a320b4d7806a235674f5f8b7b02fbb46958e54 (patch)
tree81e8584b2924d52eadc122832830ab8230ef4b0c
parent6455d2145f337a923f66995da16f830a195913d9 (diff)
downloadaur-99a320b4d7806a235674f5f8b7b02fbb46958e54.tar.gz
update to 0.13.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md17
-rw-r--r--PKGBUILD5
3 files changed, 21 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index feb24402cf3d..a69c9982ba6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apollo-rover
pkgdesc = CLI for Apollo's suite of GraphQL developer productivity tools
- pkgver = 0.12.2
+ pkgver = 0.13.0
pkgrel = 1
url = https://github.com/apollographql/rover
install = rover.install
@@ -12,7 +12,7 @@ pkgbase = apollo-rover
depends = zlib
replaces = apollo-rover-fed2
options = !lto
- source = apollo-rover-0.12.2.tar.gz::https://github.com/apollographql/rover/archive/v0.12.2.tar.gz
- sha256sums = bbb04e68a8772f46daae1b19840640026f1ba8d7202557b15a90b10259ec3090
+ source = apollo-rover-0.13.0.tar.gz::https://github.com/apollographql/rover/archive/v0.13.0.tar.gz
+ sha256sums = f93357b61135788a0b76d0dc6cf10cd8235ae58fcc1b53b953138adb94d48b9b
pkgname = apollo-rover
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 61be4fa31669..119cb7157875 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -4,7 +4,7 @@ All notable changes to Rover will be documented in this file.
This project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
-<!-- # [x.x.x] (unreleased) - 2022-mm-dd
+<!-- # [x.x.x] (unreleased) - 2023-mm-dd
> Important: x potentially breaking changes below, indicated by **❗ BREAKING ❗**
@@ -16,6 +16,21 @@ This project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.htm
## 📚 Documentation -->
+
+# [0.13.0] - 2023-03-10
+
+## 🚀 Features
+
+- **Dynamic templates - @dbanty, #1388**
+
+ Rover now fetches templates from a GraphQL API. New templates can be contributed to [the templates repo](https://github.com/apollographql/templates) and will not require a new release of Rover to be used. To see the latest templates, run `rover template list`.
+
+## 🐛 Fixes
+
+- **Fixes behavior of `--router-config` in `rover dev` - @EverlastingBugstopper, #1536 fixes #1535**
+
+ Older versions of Rover did not respect the `supergraph` section of the `--router-config` file. This has been fixed in v0.13.0.
+
# [0.12.2] - 2023-02-23
## 🚀 Features
diff --git a/PKGBUILD b/PKGBUILD
index a58922ff1304..0aa477608f59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=apollo-rover
_pkg=rover
-pkgver=0.12.2
+pkgver=0.13.0
pkgrel=1
pkgdesc="CLI for Apollo's suite of GraphQL developer productivity tools"
arch=('x86_64')
@@ -15,7 +15,7 @@ options=('!lto')
install=rover.install
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('bbb04e68a8772f46daae1b19840640026f1ba8d7202557b15a90b10259ec3090')
+sha256sums=('f93357b61135788a0b76d0dc6cf10cd8235ae58fcc1b53b953138adb94d48b9b')
prepare() {
cd "$_pkg-$pkgver"
@@ -25,7 +25,6 @@ prepare() {
build() {
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
-
cd "$_pkg-$pkgver"
cargo build --frozen --release --all-features
}