summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-09-22 16:40:31 -0500
committerLuis Martinez2022-09-22 16:40:31 -0500
commit9b247b1b369f9b5bb23c7d1dc2119865301cd81b (patch)
tree081becc9b7fbf192a59d70864cd705d7e3d4bb26
parenta7aeb4d87d29f2d4f33114e55339cebc637aa24e (diff)
downloadaur-9b247b1b369f9b5bb23c7d1dc2119865301cd81b.tar.gz
update to 0.9.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md34
-rw-r--r--PKGBUILD6
3 files changed, 40 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0af0d76d401..599ace996c1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apollo-rover
pkgdesc = CLI for Apollo's suite of GraphQL developer productivity tools
- pkgver = 0.8.2
+ pkgver = 0.9.0
pkgrel = 1
url = https://github.com/apollographql/rover
install = rover.install
@@ -12,7 +12,7 @@ pkgbase = apollo-rover
depends = zlib
replaces = apollo-rover-fed2
options = !lto
- source = apollo-rover-0.8.2.tar.gz::https://github.com/apollographql/rover/archive/v0.8.2.tar.gz
- sha256sums = f6e6edf08fc95cf6ac56032b0752565d14c46a584f85b968c103ab1504567c78
+ source = apollo-rover-0.9.0.tar.gz::https://github.com/apollographql/rover/archive/v0.9.0.tar.gz
+ sha256sums = bd829fa68823fb70b7d426fd4a416706a4f7c9ce6334c147c8cb06ce2a6a0a56
pkgname = apollo-rover
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 2817aee69216..b1cd1f5d3eee 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -22,6 +22,40 @@ This project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.htm
## 📚 Documentation -->
+# [0.9.0] - 2022-09-22
+
+## 🚀 Features
+
+- **`rover template` command suite - @dbanty, @michael-watson, @EverlastingBugstopper, #1287**
+
+ Two new commands have made their way to Rover: `rover template list` and `rover template use`. These commands provide a similar experience to `create-react-app`, and allow you to extract GraphQL project templates to your local machine. Check out [the docs](https://www.apollographql.com/docs/rover/commands/template/) for more on this new functionality.
+
+- **`rover dev` to facilitate developing a supergraph on your local machine - @EverlastingBugstopper, #1190**
+
+ `rover dev` allows you to join multiple running subgraph servers together into a local supergraph, providing the ability to run queries and inspect query plans with Apollo Sandbox. Check out [the docs](https://www.apollographql.com/docs/rover/commands/dev) for more on this new functionality.
+
+- **If E013 is thrown and `$APOLLO_KEY` is set, give a more helpful suggestion - @ptondereau, #1284, #1285**
+
+ If Studio fails to recognize an API key and `APOLLO_KEY` is set, recommend unsetting the environment variable to use `--profile default` instead.
+
+## 🐛 Fixes
+
+- **Remove useless stdout line for composition results - @ptondereau, #1124, #1291**
+
+## 🛠 Maintenance
+
+- **Link directly to API Keys page in Studio - @abernix, #1202**
+
+ The `rover config auth` command will now provide a link that takes you directly to the "API Keys" page where you can create a Personal API Key, rather than a page that requires you to click through to another page.
+
+- **Prefer "supergraph schema" terminology to "gateway" - @EverlastingBugstopper, #1239, #1332**
+
+ `rover subgraph publish` now refers to updating the "supergraph schema" as opposed to updating the "gateway," since supergraph schema consumers can be routers and/or gateways now.
+
+## 📚 Documentation
+
+- **Fix a few typos in `ARCHITECTURE.md` - @dbanty, #1289**
+
# [0.8.2] - 2022-09-06
## 🚀 Features
diff --git a/PKGBUILD b/PKGBUILD
index a0014d2ad5c9..f80ac972c16e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=apollo-rover
-pkgver=0.8.2
+pkgver=0.9.0
pkgrel=1
pkgdesc="CLI for Apollo's suite of GraphQL developer productivity tools"
arch=('x86_64')
@@ -13,8 +13,8 @@ replaces=('apollo-rover-fed2')
options=('!lto')
install=rover.install
changelog=CHANGELOG.md
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('f6e6edf08fc95cf6ac56032b0752565d14c46a584f85b968c103ab1504567c78')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('ba3dd64340176bdd418261ad4c05e9f4cd32531bfcb0b9fcec10c2a7b1bc6eb7')
prepare() {
cd "rover-$pkgver"