summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-06-12 15:09:15 -0500
committerLuis Martinez2022-06-12 15:09:15 -0500
commit9d695bb88d220d451cf7e2c4369478149fc2d0cc (patch)
treef710f93578611ac366f9b6b23a75a0984415993d
parenteb05217fe6b1b2b1a18171a84e647a6978dc4e23 (diff)
downloadaur-9d695bb88d220d451cf7e2c4369478149fc2d0cc.tar.gz
update to 0.7.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md27
-rw-r--r--PKGBUILD4
3 files changed, 32 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0ab3ecb6d4a..2dbd44d97e23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apollo-rover
pkgdesc = CLI for Apollo's suite of GraphQL developer productivity tools
- pkgver = 0.6.0
+ pkgver = 0.7.0
pkgrel = 1
url = https://github.com/apollographql/rover
install = rover.install
@@ -12,7 +12,7 @@ pkgbase = apollo-rover
depends = zlib
replaces = apollo-rover-fed2
options = !lto
- source = apollo-rover-0.6.0.tar.gz::https://github.com/apollographql/rover/archive/v0.6.0.tar.gz
- sha256sums = 2dfe76e29f069baa837092ecfa33b8e8505e59c03be39f291285a6bfda88cf09
+ source = apollo-rover-0.7.0.tar.gz::https://github.com/apollographql/rover/archive/v0.7.0.tar.gz
+ sha256sums = e8e271a084123feffac8c0a566402c0323cb7e1ea37f8c740b9fb883f23cad80
pkgname = apollo-rover
diff --git a/CHANGELOG.md b/CHANGELOG.md
index fd6468f0d1c2..9c325d6805f0 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -18,6 +18,33 @@ This project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.htm
## 📚 Documentation -->
+# [0.7.0] - 2022-06-09
+
+## 🚀 Features
+
+- **Adds `readme fetch` and `readme publish` - @cy, #1128, #1141**
+
+ Adds support for fetching and publishing Apollo Studio graph variant READMEs with `rover readme publish` and `rover readme fetch` commands. Usage for these commands can be found by running `rover readme --help` and documentation can be found [on our docs site](https://www.apollographql.com/docs/rover/readmes).
+
+## 🐛 Fixes
+
+- **Fix the endpoint `rover-client` uses to fetch Apollo Studio's GraphQL schema- @EverlastingBugstopper, 1126**
+
+ As of v0.6.0, Rover sends all Apollo Studio requests to the new public platform API. When this change was introduced, we changed where we issued our GraphQL requests, but did not update the build step that fetches the schema which could lead to mismatched types. This is now fixed, fields in the public platform API match codegen.
+
+- **Fix typo in the environment variable `rover-client` uses to fetch Apollo Studio's GraphQL schema - @EverlastingBugstopper, #1125**
+ `s/APOLLO_GPAPHQL_SCHEMA_URL/APOLLO_GRAPHQL_SCHEMA_URL`
+
+## 📚 Documentation
+
+- **Schema checks are now free - @StephenBarlow, #1131**
+
+ Update the documentation to remove references to schema checks being a paid feature, since [they are now free](https://www.apollographql.com/blog/announcement/platform/schema-checks-and-launches-are-now-available-for-free-in-apollo-studio/)!
+
+- **Update ARCHITECTURE.md - @cy #1129**
+
+ Update and clarify a few points in ARCHITECTURE.md.
+
# [0.6.0] - 2022-05-03
> Important: 1 breaking change below, indicated by **❗ BREAKING ❗**
diff --git a/PKGBUILD b/PKGBUILD
index bde4c8fcc812..a62a4524a0d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=apollo-rover
-pkgver=0.6.0
+pkgver=0.7.0
pkgrel=1
pkgdesc="CLI for Apollo's suite of GraphQL developer productivity tools"
arch=('x86_64')
@@ -14,7 +14,7 @@ options=('!lto')
install=rover.install
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('2dfe76e29f069baa837092ecfa33b8e8505e59c03be39f291285a6bfda88cf09')
+sha256sums=('e8e271a084123feffac8c0a566402c0323cb7e1ea37f8c740b9fb883f23cad80')
prepare() {
cd "rover-$pkgver"