summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-05-04 11:38:03 -0500
committerLuis Martinez2022-05-04 11:38:03 -0500
commiteb05217fe6b1b2b1a18171a84e647a6978dc4e23 (patch)
tree7c0f3a5ef3eb376dfda3ae665fcadfa697fa07ae
parente0cd9233b974f0ec6e3bddf17266a5abb9c2f0a0 (diff)
downloadaur-eb05217fe6b1b2b1a18171a84e647a6978dc4e23.tar.gz
update to 0.6.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md42
-rw-r--r--PKGBUILD4
3 files changed, 47 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5edc95342137..f0ab3ecb6d4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apollo-rover
pkgdesc = CLI for Apollo's suite of GraphQL developer productivity tools
- pkgver = 0.5.4
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/apollographql/rover
install = rover.install
@@ -12,7 +12,7 @@ pkgbase = apollo-rover
depends = zlib
replaces = apollo-rover-fed2
options = !lto
- source = apollo-rover-0.5.4.tar.gz::https://github.com/apollographql/rover/archive/v0.5.4.tar.gz
- sha256sums = 1728ee7eb5d87d9838972c1c441a7323315ded01c09d1edc7cf65c0e201a9fc9
+ source = apollo-rover-0.6.0.tar.gz::https://github.com/apollographql/rover/archive/v0.6.0.tar.gz
+ sha256sums = 2dfe76e29f069baa837092ecfa33b8e8505e59c03be39f291285a6bfda88cf09
pkgname = apollo-rover
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 16e08108927e..fd6468f0d1c2 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -18,6 +18,48 @@ This project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.htm
## 📚 Documentation -->
+# [0.6.0] - 2022-05-03
+
+> Important: 1 breaking change below, indicated by **❗ BREAKING ❗**
+
+## ❗ BREAKING ❗
+
+- **Use Apollo's Platform API - @pcarrier, #1074**
+
+ Rover now uses Apollo's Platform API instead of the old Studio API. The breaking change is that the hostname is now `api.apollographql.com` where it used to be `graphql.api.apollographql.com`, you may need to update your firewall rules. Other behavior should remain unchanged.
+
+## 🐛 Fixes
+
+- **Fixes Input Value Definition block string encoding for descriptions. - @lrlna, #1116 # fixes #1088**
+
+ Input values are now multilined when a description is present to allow for a more readable generated SDL.
+
+## 🛠 Maintenance
+
+- **Removes upper bound on Node engines for npm installer - @EverlastingBugstopper, #1120 fixes #1119**
+
+ Previously, Rover required that your node engine was between v14 and v17. We have removed the upper bound on this limit so you can now use Node 18 and any future versions.
+
+- **Adds `cargo xtask docs` - @EverlastingBugstopper, #1118**
+
+ Developers of the Rover project can now run `cargo xtask docs` to spin up a local netlify server with your local docset. After running the command, you can navigate to http://localhost:8000/rover in your browser and changes you make to ./docs/source/**.md files will be updated automatically on save.
+
+- **Updates dependencies - @renovate-bot, #1117**
+
+ `node` 16.14.2 -> 16.15.0
+ `npm` 8.7.0 -> 8.8.0
+ `os_info` 3.2 -> 3.3
+
+- **Removes unused dependencies - @EverlastingBugstopper, #1113**
+
+- **Separate Studio client code from generalized GraphQL client code - @Geal, #1061**
+
+ Introduces the `launchpad` workspace crate which contains operations not specific to Apollo Studio such as:
+
+ - launching GraphQL queries using reqwest
+ - running an introspection query on a graph
+ - transforming a JSON SDL to a schema
+
# [0.5.4] - 2022-04-26
## 🐛 Fixes
diff --git a/PKGBUILD b/PKGBUILD
index d8be18670540..bde4c8fcc812 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=apollo-rover
-pkgver=0.5.4
+pkgver=0.6.0
pkgrel=1
pkgdesc="CLI for Apollo's suite of GraphQL developer productivity tools"
arch=('x86_64')
@@ -14,7 +14,7 @@ options=('!lto')
install=rover.install
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('1728ee7eb5d87d9838972c1c441a7323315ded01c09d1edc7cf65c0e201a9fc9')
+sha256sums=('2dfe76e29f069baa837092ecfa33b8e8505e59c03be39f291285a6bfda88cf09')
prepare() {
cd "rover-$pkgver"