summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJSH2015-06-08 15:05:30 -0400
committerJSH2015-06-08 15:05:30 -0400
commit6296923f16b91cbd3d342e442f9f7e380d0ab79b (patch)
tree31f23487b7db20acc6a8c075e6096d1193457034
downloadaur-6296923f16b91cbd3d342e442f9f7e380d0ab79b.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD56
-rw-r--r--apoo.install11
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff683315b6e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = apoo
+ pkgdesc = An environment for a first course in assembly language programming
+ pkgver = 2.2
+ pkgrel = 2
+ url = http://www.ncc.up.pt/Apoo/
+ install = apoo.install
+ arch = any
+ license = GPL
+ makedepends = gendesk
+ depends = pygtk>=2.10
+ depends = desktop-file-utils
+ options = !emptydirs
+ source = http://http.debian.net/debian/pool/main/a/apoo/apoo_2.2.orig.tar.gz
+ md5sums = d27455bbefe361d53c95ba9d746f52a6
+
+pkgname = apoo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51310b58969f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: JSH <jsh6789 at gmail dot com>
+
+pkgname=apoo
+pkgver=2.2
+pkgrel=2
+pkgdesc="An environment for a first course in assembly language programming"
+arch=('any')
+url="http://www.ncc.up.pt/Apoo/"
+license=('GPL')
+depends=('pygtk>=2.10' 'desktop-file-utils')
+makedepends=('gendesk')
+options=(!emptydirs)
+install=apoo.install
+source=("http://http.debian.net/debian/pool/main/a/apoo/${pkgname}_${pkgver}.orig.tar.gz")
+md5sums=('d27455bbefe361d53c95ba9d746f52a6')
+_categories="Education;Science;ComputerScience;"
+
+prepare() {
+
+ gendesk
+
+ cd "$pkgname-$pkgver"
+
+# python2 fix
+ sed -i 's|/usr/bin/python|/usr/bin/python2|g' apoo *.py
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # Install program
+ install -Dm755 apoo "$pkgdir/usr/bin/apoo"
+ for _file in *.py; do \
+ install -Dm755 "$_file" "$pkgdir/usr/lib/$pkgname/$_file"
+ done
+
+ # Install documentation
+ cd docs
+ for _file in *; do \
+ install -Dm644 "$_file" "$pkgdir/usr/share/doc/$pkgname/$_file"
+ done
+
+ cd ../html
+ for _file in *; do \
+ install -Dm644 "$_file" "$pkgdir/usr/share/doc/$pkgname/html/$_file"
+ done
+
+ cd ../examples
+ for _file in *; do \
+ install -Dm644 "$_file" "$pkgdir/usr/share/doc/$pkgname/examples/$_file"
+ done
+
+ # Install .desktop
+ cd "$srcdir"
+ install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
diff --git a/apoo.install b/apoo.install
new file mode 100644
index 000000000000..b8c7ebf27b7e
--- /dev/null
+++ b/apoo.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}