summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-01-26 09:04:06 -0700
committerMark Wagie2022-01-26 09:04:06 -0700
commit9ceeec39f609c2bc9b7b15dca4e456ef8b21f859 (patch)
treee441e095c1c28fe4770cd0a63570b67d1368d966
parent6d8a009ebee26c027fcb184a77ffd0adf0531f03 (diff)
downloadaur-9ceeec39f609c2bc9b7b15dca4e456ef8b21f859.tar.gz
fix build
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
-rw-r--r--apostrophe.patch19
4 files changed, 33 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0b008c13359..36cfa84ed4fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = apostrophe
pkgdesc = A distraction free Markdown editor for GNU/Linux made with GTK+
pkgver = 2.5
- pkgrel = 1
+ pkgrel = 2
url = https://world.pages.gitlab.gnome.org/apostrophe
arch = any
license = GPL3
@@ -22,6 +22,8 @@ pkgbase = apostrophe
optdepends = texlive-latexextra: for the pdftex module
optdepends = mathjax: for formula preview
source = https://gitlab.gnome.org/World/apostrophe/-/archive/v2.5/apostrophe-v2.5.tar.gz
+ source = apostrophe.patch
sha256sums = 366b239ea7bb720c11fc7344827b6739e4983132c9932aa4705a3b88533d75e4
+ sha256sums = 6471631544fd666074ade2aec0e15c48a09735f8305ce64e8ba5091b28c20039
pkgname = apostrophe
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..62e4c78778c2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!apostrophe.patch
diff --git a/PKGBUILD b/PKGBUILD
index b9b2bf817d8a..59e89b86ef48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=apostrophe
pkgver=2.5
-pkgrel=1
+pkgrel=2
pkgdesc="A distraction free Markdown editor for GNU/Linux made with GTK+"
arch=('any')
url="https://world.pages.gitlab.gnome.org/apostrophe"
@@ -13,8 +13,15 @@ makedepends=('meson' 'gobject-introspection' 'sassc')
optdepends=('texlive-latexextra: for the pdftex module'
'mathjax: for formula preview')
checkdepends=('appstream-glib')
-source=("https://gitlab.gnome.org/World/apostrophe/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-sha256sums=('366b239ea7bb720c11fc7344827b6739e4983132c9932aa4705a3b88533d75e4')
+source=("https://gitlab.gnome.org/World/apostrophe/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
+ "$pkgname.patch")
+sha256sums=('366b239ea7bb720c11fc7344827b6739e4983132c9932aa4705a3b88533d75e4'
+ '6471631544fd666074ade2aec0e15c48a09735f8305ce64e8ba5091b28c20039')
+
+prepare() {
+ cd "$pkgname-v$pkgver"
+ patch -Np1 -i "$srcdir/$pkgname.patch"
+}
build() {
arch-meson "$pkgname-v$pkgver" build
diff --git a/apostrophe.patch b/apostrophe.patch
new file mode 100644
index 000000000000..cc3888602587
--- /dev/null
+++ b/apostrophe.patch
@@ -0,0 +1,19 @@
+diff '--color=auto' --unified --recursive --text apostrophe-v2.5/data/meson.build apostrophe-v2.5.patched/data/meson.build
+--- apostrophe-v2.5/data/meson.build 2021-08-29 04:14:59.000000000 +0200
++++ apostrophe-v2.5.patched/data/meson.build 2022-01-18 20:28:16.437498834 +0100
+@@ -2,7 +2,6 @@
+ desktop_conf = configuration_data()
+ desktop_conf.set('icon', application_id)
+ desktop_file = i18n.merge_file(
+- 'desktop',
+ input: configure_file(
+ input: 'org.gnome.gitlab.somas.Apostrophe.desktop.in.in',
+ output: '@BASENAME@',
+@@ -46,7 +45,6 @@
+ # )
+
+ appdata_file = i18n.merge_file(
+- 'appdata',
+ input: metainfo_configured,
+ output: '@0@.metainfo.xml'.format(application_id),
+ po_dir: podir,