summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-03-10 09:23:50 -0700
committerMark Wagie2022-03-10 09:23:50 -0700
commitd54a088b4981634d84c257ecc8b942e15c74b69f (patch)
treef6bfc1a6b33cf9c9eba6894597042c7a1582e97f
parent9ceeec39f609c2bc9b7b15dca4e456ef8b21f859 (diff)
downloadaur-d54a088b4981634d84c257ecc8b942e15c74b69f.tar.gz
various fixes & improvements
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
-rw-r--r--apostrophe-NEWS172
4 files changed, 191 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36cfa84ed4fa..8566b7becfab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = apostrophe
pkgdesc = A distraction free Markdown editor for GNU/Linux made with GTK+
pkgver = 2.5
- pkgrel = 2
+ pkgrel = 3
url = https://world.pages.gitlab.gnome.org/apostrophe
+ changelog = apostrophe-NEWS
arch = any
license = GPL3
checkdepends = appstream-glib
@@ -12,12 +13,14 @@ pkgbase = apostrophe
depends = gspell
depends = libhandy
depends = otf-fira-mono
+ depends = otf-fira-sans
depends = python-cairo
depends = python-gobject
depends = python-levenshtein
depends = python-pyenchant
depends = python-pypandoc
depends = python-regex
+ depends = python-setuptools
depends = webkit2gtk
optdepends = texlive-latexextra: for the pdftex module
optdepends = mathjax: for formula preview
diff --git a/.gitignore b/.gitignore
index 62e4c78778c2..f8ef36f9d81b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,3 +6,4 @@
!PKGBUILD
!.SRCINFO
!apostrophe.patch
+!apostrophe-NEWS
diff --git a/PKGBUILD b/PKGBUILD
index 59e89b86ef48..aaecd35be3b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=apostrophe
pkgver=2.5
-pkgrel=2
+pkgrel=3
pkgdesc="A distraction free Markdown editor for GNU/Linux made with GTK+"
arch=('any')
url="https://world.pages.gitlab.gnome.org/apostrophe"
license=('GPL3')
-depends=('gspell' 'libhandy' 'otf-fira-mono' 'python-cairo' 'python-gobject'
- 'python-levenshtein' 'python-pyenchant' 'python-pypandoc' 'python-regex'
- 'webkit2gtk')
+depends=('gspell' 'libhandy' 'otf-fira-mono' 'otf-fira-sans' 'python-cairo'
+ 'python-gobject' 'python-levenshtein' 'python-pyenchant' 'python-pypandoc'
+ 'python-regex' 'python-setuptools' 'webkit2gtk')
makedepends=('meson' 'gobject-introspection' 'sassc')
optdepends=('texlive-latexextra: for the pdftex module'
'mathjax: for formula preview')
checkdepends=('appstream-glib')
+changelog="$pkgname-NEWS"
source=("https://gitlab.gnome.org/World/apostrophe/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
"$pkgname.patch")
sha256sums=('366b239ea7bb720c11fc7344827b6739e4983132c9932aa4705a3b88533d75e4'
@@ -21,6 +22,15 @@ sha256sums=('366b239ea7bb720c11fc7344827b6739e4983132c9932aa4705a3b88533d75e4'
prepare() {
cd "$pkgname-v$pkgver"
patch -Np1 -i "$srcdir/$pkgname.patch"
+
+ # Bug 1953395 - Apostrophe can't export to HTML
+ sed -i 's|/app/share/fonts/FiraSans-Regular.ttf|/usr/share/fonts/mozilla-fira/FiraSans-Regular.otf|' \
+ data/media/css/web/base.css
+ sed -i 's|/app/share/fonts/FiraMono-Regular.ttf|/usr/share/fonts/mozilla-fira/FiraMono-Regular.otf|' \
+ data/media/css/web/base.css
+
+ # W: hidden-file-or-dir
+ rm apostrophe/.pylintrc
}
build() {
diff --git a/apostrophe-NEWS b/apostrophe-NEWS
new file mode 100644
index 000000000000..7c027a08afa4
--- /dev/null
+++ b/apostrophe-NEWS
@@ -0,0 +1,172 @@
+Version 2.5
+~~~~~~~~~~~~~~~
+Released: 2021-08-28
+
+Features:
+- Added Sepia Mode
+- Improved exported HTML on small screens
+- Updated metadata and runtime version
+
+Version 2.4
+~~~~~~~~~~~~~~~
+Released: 2021-03-10
+
+Bugfixes:
+- Fixed a bug where the cursor could go over the bottom of the window
+- Fixed a bug where in certain circumstances the bottom line couldn't be clicked
+- Improved behaviour when dealing with unsaved files.
+- Improved start/end sentence detection in Focus Mode
+- Small improvements in the headerbar title
+- Cleaned a little bit the Shortcuts Window
+
+Version 2.3
+~~~~~~~~~~~~~~~
+Released: 2021-03-01
+
+Features:
+- New export dialog
+- Improved Reveal.js slideshow exports
+- Better input/output handling
+- Inhibit logout if the document is not saved
+- Migrate to xelatex
+- Better internal path handling
+- New animated progressbar on saving
+- Strict sandboxing support
+
+Bugfixes:
+- Undo/redo improvements
+- Fixes for bad markdown parsing of unordered lists
+
+Version 2.2.0.3
+~~~~~~~~~~~~~~~
+Released: 2020-05-04
+
+Bugfixes:
+ - Better wording for some areas
+ - Fixed some issues where Apostrophe couldn't open files from CLI/context menu
+ - Now Apostrophe checks if there is unsaved work before exiting via CTRL + Q/W
+ - Better parsing of weblinks and links to files
+ - Fixed a bug where the bottom portion of the screen was insensitive to mouse input
+
+Version 2.2.0.2
+~~~~~~~~~~~~~~~
+Released: 2020-04-20
+
+Bugfixes:
+ - Fixes for the Elementary OS platform
+ - Fixed some links and metadata
+
+Version 2.2.0.1
+~~~~~~~~~~~~~~~
+Released: 2020-04-18
+
+Features:
+ - New headerbar design
+ - New preview modes, with the option to sync them to the edit view
+ - New preview mode selector
+ - New theme selector
+ - Rework the autohiding mechanism; now the headerbar fades away when typing, only to reappear when the cursor moves to the top portion of the window
+ - Now the content of the texview goes visually bellow the headerbar
+ - Overall better styling
+ - Added Hemingway mode, which disables the backspace key
+ - Added Github Flavoured Markdow, MultiMarkdown, Pandoc's Markdown and Commonmark support, being CommonMark the default from now on
+ - New stats counter, with the option to show count of characters/words/sentences/paragrafs/reading time
+ - Better handling of DnD events
+ - Export to A4 by default
+ - Technical improvements
+ * Port of the buildsystem to Meson. Now you can hit the "build" button on Builder and everything works as expected
+ * Port to gspell
+ * Partial port to gresources
+ * Overall refactorization of the codebase
+ * General bugfixes and improvements
+
+Version 2.1.5
+~~~~~~~~~~~~~
+Released: 2019-03-10
+
+Features:
+ - Added italian language
+ - Initial themes support: now apostrophe adapts his colors to the current GTK theme
+ - Disabled scroll gradient, can be enabled in the preferences dialog
+ - Allow to disable headerbar autohidding in Dconf
+ - Now a single click is enough to open files in the recent files popover
+ - Spellchecking status is now saved between sessions
+ - Minor UI fixes
+ - Added -d flag to enable webdev tools
+
+Version 2.1.4
+~~~~~~~~~~~~~
+Released: 2018-12-06
+
+Features:
+ - Updated css styles.
+
+Version 2.1.3
+~~~~~~~~~~~~~
+Released: 2018-11-28
+
+Features:
+ - This release features a new logo, polishes the Appmenu, fixes usability bugs and flatpak related bugs.
+
+Version 2.1.2
+~~~~~~~~~~~~~
+Released: 2018-07-27
+
+Features:
+ - This release provides a fix to a bug that caused Apostrophe to not mark properly **bold**, *cursive*, and ***bold and cursive*** words.
+
+Version 2.1.1
+~~~~~~~~~~~~~
+Released: 2018-07-26
+
+Bugfixes:
+ - One on focus mode which caused the lines to be highlighted on edit rather than on click
+ - Non symbolic icons on the searchbar
+
+Version 2.1.0
+~~~~~~~~~~~~~
+Released: 2018-07-18
+
+Features:
+ - Drop AppMenu support
+ - HeaderBar and menus redesign, with a new unified menu and quick access buttons on the headerbar
+ - Now the fullscreen view shows a headerbar when the cursor approaches the top of the screen
+ - A new unified export dialog, with updated options, and quick access to pdf, odt and html export
+ - Bugfixes.
+
+Version 2.0.4
+~~~~~~~~~~~~~
+Released: 2018-06-24
+
+Features:
+ - Now the menu is a Popover instead a regular menu.
+ - The headerbar matches the theme selected for the application.
+ - Updated translations.
+
+Version 2.0.3
+~~~~~~~~~~~~~
+Released: 2018-06-14
+
+Bugfixes:
+ - Small bug fixes, updated links.
+
+Version 2.0.2
+~~~~~~~~~~~~~
+Released: 2018-05-16
+
+Bugfixes:
+ - Fix a bug with the preview mode.
+
+Version 2.0.1
+~~~~~~~~~~~~~
+Released: 2018-05-14
+
+Bugfixes:
+ - Don’t use env variable to check if in flatpak.
+
+Version 2.0.0
+~~~~~~~~~~~~~
+Released: 2018-05-12
+
+Features:
+ - First re-release