summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-09-10 10:24:36 -0600
committerMark Wagie2022-09-10 10:24:36 -0600
commitd7f144bcc35b5e360aabbac042563009eec0cd59 (patch)
tree1b1fc07a4ce13d18e6497723e73bc27c4253682e
parent8f25447294df20e667ac51dcf4e8767747a736ff (diff)
downloadaur-d7f144bcc35b5e360aabbac042563009eec0cd59.tar.gz
Allow building with webkitgtk 4.1
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore2
-rw-r--r--Allow-building-with-webkitgtk-4.1.patch61
-rw-r--r--PKGBUILD15
-rw-r--r--apostrophe-NEWS217
5 files changed, 75 insertions, 228 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f10357eb4bb..0a9d522c496c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = apostrophe
pkgdesc = A distraction free Markdown editor for GNU/Linux made with GTK+
pkgver = 2.6.3
- pkgrel = 3
+ pkgrel = 4
url = https://world.pages.gitlab.gnome.org/apostrophe
- changelog = apostrophe-NEWS
arch = any
license = GPL3
checkdepends = appstream-glib
@@ -12,7 +11,6 @@ pkgbase = apostrophe
makedepends = sassc
depends = gspell
depends = libhandy
- depends = lua-lpeg
depends = otf-fira-mono
depends = otf-fira-sans
depends = python-cairo
@@ -22,10 +20,12 @@ pkgbase = apostrophe
depends = python-pypandoc
depends = python-regex
depends = python-setuptools
- depends = webkit2gtk
+ depends = webkit2gtk-4.1
optdepends = texlive-latexextra: for the pdftex module
optdepends = mathjax: for formula preview
source = https://gitlab.gnome.org/World/apostrophe/-/archive/v2.6.3/apostrophe-v2.6.3.tar.gz
+ source = Allow-building-with-webkitgtk-4.1.patch
sha256sums = 6f73c80146af0820ec705ec8b32ec64f0f323f51de6b6a4cfd4d02f0719876f3
+ sha256sums = c5c64aa312a17fcf761b0da956147f91532c8c43b33d608ca3acb6f10bd53d12
pkgname = apostrophe
diff --git a/.gitignore b/.gitignore
index 5cb45e05c55d..3bf9370e442f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,4 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
-!apostrophe-NEWS
+!Allow-building-with-webkitgtk-4.1.patch
diff --git a/Allow-building-with-webkitgtk-4.1.patch b/Allow-building-with-webkitgtk-4.1.patch
new file mode 100644
index 000000000000..9e409b8e7cd3
--- /dev/null
+++ b/Allow-building-with-webkitgtk-4.1.patch
@@ -0,0 +1,61 @@
+From: Jeremy Bicha <jeremy.bicha@canonical.com>
+Date: Wed, 31 Aug 2022 06:24:41 -0400
+Subject: Allow building with webkitgtk 4.1
+
+4.1 is the same as 4.0 except that it uses libsoup3
+
+https://gitlab.gnome.org/World/apostrophe/-/merge_requests/256
+---
+ apostrophe/inline_preview.py | 5 ++++-
+ apostrophe/preview_handler.py | 5 ++++-
+ apostrophe/preview_web_view.py | 5 ++++-
+ 3 files changed, 12 insertions(+), 3 deletions(-)
+
+diff --git a/apostrophe/inline_preview.py b/apostrophe/inline_preview.py
+index 6e2fcc8..55ef85c 100644
+--- a/apostrophe/inline_preview.py
++++ b/apostrophe/inline_preview.py
+@@ -22,7 +22,10 @@ from urllib.parse import unquote
+ import gi
+
+ gi.require_version("Gtk", "3.0")
+-gi.require_version("WebKit2", "4.0")
++try:
++ gi.require_version('WebKit2', '4.1')
++except ValueError:
++ gi.require_version('WebKit2', '4.0')
+ from gi.repository import Gtk, Gdk, GdkPixbuf, GLib
+ from gi.repository import WebKit2
+ from apostrophe import latex_to_PNG, markup_regex
+diff --git a/apostrophe/preview_handler.py b/apostrophe/preview_handler.py
+index f2edd61..a1b9981 100644
+--- a/apostrophe/preview_handler.py
++++ b/apostrophe/preview_handler.py
+@@ -22,7 +22,10 @@ import gi
+ from apostrophe.preview_renderer import PreviewRenderer
+ from apostrophe.settings import Settings
+
+-gi.require_version('WebKit2', '4.0')
++try:
++ gi.require_version('WebKit2', '4.1')
++except ValueError:
++ gi.require_version('WebKit2', '4.0')
+ from gi.repository import WebKit2, GLib, Gtk, GObject
+
+ from apostrophe.preview_converter import PreviewConverter
+diff --git a/apostrophe/preview_web_view.py b/apostrophe/preview_web_view.py
+index bfd932c..f2c7146 100644
+--- a/apostrophe/preview_web_view.py
++++ b/apostrophe/preview_web_view.py
+@@ -17,7 +17,10 @@ import webbrowser
+
+ import gi
+
+-gi.require_version('WebKit2', '4.0')
++try:
++ gi.require_version('WebKit2', '4.1')
++except ValueError:
++ gi.require_version('WebKit2', '4.0')
+ from gi.repository import WebKit2, GLib, GObject
+
+
diff --git a/PKGBUILD b/PKGBUILD
index 13060abcf066..720ee6e58dfd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=apostrophe
pkgver=2.6.3
-pkgrel=3
+pkgrel=4
pkgdesc="A distraction free Markdown editor for GNU/Linux made with GTK+"
arch=('any')
url="https://world.pages.gitlab.gnome.org/apostrophe"
license=('GPL3')
-depends=('gspell' 'libhandy' 'lua-lpeg' 'otf-fira-mono' 'otf-fira-sans' 'python-cairo'
+depends=('gspell' 'libhandy' 'otf-fira-mono' 'otf-fira-sans' 'python-cairo'
'python-gobject' 'python-levenshtein' 'python-pyenchant' 'python-pypandoc'
- 'python-regex' 'python-setuptools' 'webkit2gtk')
+ 'python-regex' 'python-setuptools' 'webkit2gtk-4.1')
makedepends=('meson' 'gobject-introspection' 'sassc')
optdepends=('texlive-latexextra: for the pdftex module'
'mathjax: for formula preview')
checkdepends=('appstream-glib')
-changelog="$pkgname-NEWS"
-source=("https://gitlab.gnome.org/World/apostrophe/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-sha256sums=('6f73c80146af0820ec705ec8b32ec64f0f323f51de6b6a4cfd4d02f0719876f3')
+source=("https://gitlab.gnome.org/World/apostrophe/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
+ 'Allow-building-with-webkitgtk-4.1.patch')
+sha256sums=('6f73c80146af0820ec705ec8b32ec64f0f323f51de6b6a4cfd4d02f0719876f3'
+ 'c5c64aa312a17fcf761b0da956147f91532c8c43b33d608ca3acb6f10bd53d12')
prepare() {
cd "$pkgname-v$pkgver"
@@ -28,6 +29,8 @@ prepare() {
# W: hidden-file-or-dir
rm apostrophe/.pylintrc
+
+ patch -Np1 -i ../Allow-building-with-webkitgtk-4.1.patch
}
build() {
diff --git a/apostrophe-NEWS b/apostrophe-NEWS
deleted file mode 100644
index 7203b24a4e92..000000000000
--- a/apostrophe-NEWS
+++ /dev/null
@@ -1,217 +0,0 @@
-Version 2.6.3
-~~~~~~~~~~~~~~~
-Released: 2022-04-29
-
-Bugfixes:
-- Fix a bug where the preview wouldn't be shown when opening a file from Files or the CLI
-- Fix a bug where horizontal preview wouldn't request enough space at startup
-- Removed swipe gestures from the preview panel
-
-Features:
-- Added Persian translations, updated Catalan, German , Finnish and Turkish ones
-
-Version 2.6.2
-~~~~~~~~~~~~~~~
-Released: 2022-03-31
-
-Bugfixes:
-- Fix handling of windowed preview mode on some circumstances
-
-Features:
-- Add proper titles to the preview window
-- Update translations
-
-Version 2.6.1
-~~~~~~~~~~~~~~~
-Released: 2022-03-20
-
-Bugfixes:
-- A small bug in 2.6 which didn't allow to save files
-
-Version 2.6
-~~~~~~~~~~~~~~~
-Released: 2022-03-19
-
-Features:
-- Implemented multiwindow support
-- Save window state on exit
-- Ported to libhandy
-- Improved the overall UI
-- New animations
-- Follow the Dark Mode global preference
-- Add an "automatic" color mode
-- Improve the High Contrast styles
-- Improve inline preview markup
-
-Version 2.5
-~~~~~~~~~~~~~~~
-Released: 2021-08-28
-
-Features:
-- Added Sepia Mode
-- Improved exported HTML on small screens
-- Updated metadata and runtime version
-
-Version 2.4
-~~~~~~~~~~~~~~~
-Released: 2021-03-10
-
-Bugfixes:
-- Fixed a bug where the cursor could go over the bottom of the window
-- Fixed a bug where in certain circumstances the bottom line couldn't be clicked
-- Improved behaviour when dealing with unsaved files.
-- Improved start/end sentence detection in Focus Mode
-- Small improvements in the headerbar title
-- Cleaned a little bit the Shortcuts Window
-
-Version 2.3
-~~~~~~~~~~~~~~~
-Released: 2021-03-01
-
-Features:
-- New export dialog
-- Improved Reveal.js slideshow exports
-- Better input/output handling
-- Inhibit logout if the document is not saved
-- Migrate to xelatex
-- Better internal path handling
-- New animated progressbar on saving
-- Strict sandboxing support
-
-Bugfixes:
-- Undo/redo improvements
-- Fixes for bad markdown parsing of unordered lists
-
-Version 2.2.0.3
-~~~~~~~~~~~~~~~
-Released: 2020-05-04
-
-Bugfixes:
- - Better wording for some areas
- - Fixed some issues where Apostrophe couldn't open files from CLI/context menu
- - Now Apostrophe checks if there is unsaved work before exiting via CTRL + Q/W
- - Better parsing of weblinks and links to files
- - Fixed a bug where the bottom portion of the screen was insensitive to mouse input
-
-Version 2.2.0.2
-~~~~~~~~~~~~~~~
-Released: 2020-04-20
-
-Bugfixes:
- - Fixes for the Elementary OS platform
- - Fixed some links and metadata
-
-Version 2.2.0.1
-~~~~~~~~~~~~~~~
-Released: 2020-04-18
-
-Features:
- - New headerbar design
- - New preview modes, with the option to sync them to the edit view
- - New preview mode selector
- - New theme selector
- - Rework the autohiding mechanism; now the headerbar fades away when typing, only to reappear when the cursor moves to the top portion of the window
- - Now the content of the texview goes visually bellow the headerbar
- - Overall better styling
- - Added Hemingway mode, which disables the backspace key
- - Added Github Flavoured Markdow, MultiMarkdown, Pandoc's Markdown and Commonmark support, being CommonMark the default from now on
- - New stats counter, with the option to show count of characters/words/sentences/paragrafs/reading time
- - Better handling of DnD events
- - Export to A4 by default
- - Technical improvements
- * Port of the buildsystem to Meson. Now you can hit the "build" button on Builder and everything works as expected
- * Port to gspell
- * Partial port to gresources
- * Overall refactorization of the codebase
- * General bugfixes and improvements
-
-Version 2.1.5
-~~~~~~~~~~~~~
-Released: 2019-03-10
-
-Features:
- - Added italian language
- - Initial themes support: now apostrophe adapts his colors to the current GTK theme
- - Disabled scroll gradient, can be enabled in the preferences dialog
- - Allow to disable headerbar autohidding in Dconf
- - Now a single click is enough to open files in the recent files popover
- - Spellchecking status is now saved between sessions
- - Minor UI fixes
- - Added -d flag to enable webdev tools
-
-Version 2.1.4
-~~~~~~~~~~~~~
-Released: 2018-12-06
-
-Features:
- - Updated css styles.
-
-Version 2.1.3
-~~~~~~~~~~~~~
-Released: 2018-11-28
-
-Features:
- - This release features a new logo, polishes the Appmenu, fixes usability bugs and flatpak related bugs.
-
-Version 2.1.2
-~~~~~~~~~~~~~
-Released: 2018-07-27
-
-Features:
- - This release provides a fix to a bug that caused Apostrophe to not mark properly **bold**, *cursive*, and ***bold and cursive*** words.
-
-Version 2.1.1
-~~~~~~~~~~~~~
-Released: 2018-07-26
-
-Bugfixes:
- - One on focus mode which caused the lines to be highlighted on edit rather than on click
- - Non symbolic icons on the searchbar
-
-Version 2.1.0
-~~~~~~~~~~~~~
-Released: 2018-07-18
-
-Features:
- - Drop AppMenu support
- - HeaderBar and menus redesign, with a new unified menu and quick access buttons on the headerbar
- - Now the fullscreen view shows a headerbar when the cursor approaches the top of the screen
- - A new unified export dialog, with updated options, and quick access to pdf, odt and html export
- - Bugfixes.
-
-Version 2.0.4
-~~~~~~~~~~~~~
-Released: 2018-06-24
-
-Features:
- - Now the menu is a Popover instead a regular menu.
- - The headerbar matches the theme selected for the application.
- - Updated translations.
-
-Version 2.0.3
-~~~~~~~~~~~~~
-Released: 2018-06-14
-
-Bugfixes:
- - Small bug fixes, updated links.
-
-Version 2.0.2
-~~~~~~~~~~~~~
-Released: 2018-05-16
-
-Bugfixes:
- - Fix a bug with the preview mode.
-
-Version 2.0.1
-~~~~~~~~~~~~~
-Released: 2018-05-14
-
-Bugfixes:
- - Don’t use env variable to check if in flatpak.
-
-Version 2.0.0
-~~~~~~~~~~~~~
-Released: 2018-05-12
-
-Features:
- - First re-release