summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-03-05 12:21:34 -0700
committerMark Wagie2022-03-05 12:21:34 -0700
commit33fe7483033d0eab92e197caf524d22da0824d7c (patch)
tree9a0a34c4c250ad0e7f5a6f9bd0822f27830a9b88
parenteef7afdd4391ce3fe3c02af5cea610599513b37f (diff)
downloadaur-33fe7483033d0eab92e197caf524d22da0824d7c.tar.gz
drop patch, fixed upstream
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 6 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b6824a348e9..3bb1b0ffd079 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = apostrophe-git
pkgdesc = A distraction free Markdown editor for GNU/Linux made with GTK+
- pkgver = 2.5.r31.ga7459de
- pkgrel = 2
+ pkgver = 2.5.r58.g15ccd24
+ pkgrel = 1
url = https://world.pages.gitlab.gnome.org/apostrophe
arch = any
license = GPL3
@@ -25,8 +25,6 @@ pkgbase = apostrophe-git
provides = apostrophe
conflicts = apostrophe
source = git+https://gitlab.gnome.org/World/apostrophe.git
- source = apostrophe.patch
sha256sums = SKIP
- sha256sums = 6471631544fd666074ade2aec0e15c48a09735f8305ce64e8ba5091b28c20039
pkgname = apostrophe-git
diff --git a/PKGBUILD b/PKGBUILD
index d367eca77317..12c83f844d63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Co-Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=apostrophe-git
-pkgver=2.5.r31.ga7459de
-pkgrel=2
+pkgver=2.5.r58.g15ccd24
+pkgrel=1
pkgdesc="A distraction free Markdown editor for GNU/Linux made with GTK+"
arch=('any')
url="https://world.pages.gitlab.gnome.org/apostrophe"
@@ -17,21 +17,14 @@ optdepends=('texlive-latexextra: for the pdftex module'
'mathjax: for formula preview')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://gitlab.gnome.org/World/apostrophe.git'
- "${pkgname%-git}.patch")
-sha256sums=('SKIP'
- '6471631544fd666074ade2aec0e15c48a09735f8305ce64e8ba5091b28c20039')
+source=('git+https://gitlab.gnome.org/World/apostrophe.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/${pkgname%-git}"
- patch -Np1 -i "$srcdir/${pkgname%-git}.patch"
-}
-
build() {
arch-meson -Dprofile=development "${pkgname%-git}" build
meson compile -C build