summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-03-02 01:05:07 -0700
committerMark Wagie2021-03-02 01:05:07 -0700
commit44208cf18deb370c5d1e785cef15fa41ea411555 (patch)
tree27927048a42d4631764cb4ac761167b597266de2
parentce9a5f016c090055424d5090618a058f3dc61926 (diff)
downloadaur-44208cf18deb370c5d1e785cef15fa41ea411555.tar.gz
add libhandy dep, use dev profile
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc2c6420796b..3366bf1bcc97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = apostrophe-git
pkgdesc = A distraction free Markdown editor for GNU/Linux made with GTK+
- pkgver = 2.2.0.3.r33.gff24dc1
- pkgrel = 2
+ pkgver = 2.3.r0.g5f28632
+ pkgrel = 1
url = https://somas.pages.gitlab.gnome.org/apostrophe
arch = any
license = GPL3
- checkdepends = appstream
makedepends = git
makedepends = meson
makedepends = gobject-introspection
@@ -18,6 +17,7 @@ pkgbase = apostrophe-git
depends = python-gobject
depends = python-cairo
depends = otf-fira-mono
+ depends = libhandy
optdepends = texlive-latexextra: for the pdftex module
optdepends = mathjax: for formula preview
provides = apostrophe
diff --git a/PKGBUILD b/PKGBUILD
index ad136fbb9ed4..442bd7438469 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,15 @@
# Co-Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=apostrophe-git
-pkgver=2.2.0.3.r33.gff24dc1
-pkgrel=2
+pkgver=2.3.r0.g5f28632
+pkgrel=1
pkgdesc="A distraction free Markdown editor for GNU/Linux made with GTK+"
arch=('any')
url="https://somas.pages.gitlab.gnome.org/apostrophe"
license=('GPL3')
depends=('webkit2gtk' 'gspell' 'python-pypandoc' 'python-regex' 'python-levenshtein'
- 'python-pyenchant' 'python-gobject' 'python-cairo' 'otf-fira-mono')
+ 'python-pyenchant' 'python-gobject' 'python-cairo' 'otf-fira-mono' 'libhandy')
makedepends=('git' 'meson' 'gobject-introspection')
-checkdepends=('appstream')
optdepends=('texlive-latexextra: for the pdftex module'
'mathjax: for formula preview')
provides=("${pkgname%-git}")
@@ -25,12 +24,12 @@ pkgver() {
}
build() {
- arch-meson "${pkgname%-git}" build
+ arch-meson -Dprofile=development "${pkgname%-git}" build
meson compile -C build
}
check() {
- meson test -C build
+ meson test -C build --print-errorlogs
}
package() {