summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNorth-West-Wind2023-06-11 15:10:50 +0800
committerNorth-West-Wind2023-06-11 15:10:50 +0800
commit8b255e8b7f6edbc5c0d0a8f5db07a446f3e4cb96 (patch)
tree003ed1d8f8ad4c255faa047951fbf072f2409b2f
downloadaur-8b255e8b7f6edbc5c0d0a8f5db07a446f3e4cb96.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a253b899046
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = app-librescore-appimage
+ pkgdesc = Download sheet music
+ pkgver = 2.0.92
+ pkgrel = 1
+ url = https://github.com/LibreScore/app-librescore
+ arch = any
+ license = MIT
+ depends = hicolor-icon-theme
+ options = !strip
+ source = https://github.com/LibreScore/app-librescore/releases/download/v2.0.92/LibreScore.AppImage
+ md5sums = d3f19fc8af7c01308644404ae2035b93
+
+pkgname = app-librescore-appimage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c5b71826c6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Nathan Wong, NorthWestWind <wsyn148@gmail.com>
+_pkgname=app-librescore
+pkgname=$_pkgname-appimage
+pkgver=2.0.92
+pkgrel=1
+pkgdesc="Download sheet music"
+arch=('any')
+url="https://github.com/LibreScore/app-librescore"
+license=('MIT')
+depends=('hicolor-icon-theme')
+source=("${url}/releases/download/v${pkgver}/LibreScore.AppImage")
+md5sums=('d3f19fc8af7c01308644404ae2035b93')
+options=(!strip)
+
+prepare() {
+ cd $srcdir
+
+ chmod +x ./LibreScore.AppImage
+ ./LibreScore.AppImage --appimage-extract
+}
+
+package() {
+ install -Dm755 "${srcdir}/LibreScore.AppImage" "${pkgdir}/usr/bin/librescore"
+
+ install -dm755 "${pkgdir}/usr/share/applications/"
+ cp -r --no-preserve=mode,ownership "${srcdir}/squashfs-root/share/icons" "${pkgdir}/usr/share/"
+ cp -r --no-preserve=mode,ownership "${srcdir}/squashfs-root/share/applications" "${pkgdir}/usr/share/"
+}