summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDannyChain2021-05-03 16:18:15 -0300
committerDannyChain2021-05-03 16:18:15 -0300
commitd04b66e36b459218607df02b8002bb438ecd4171 (patch)
treeb58b2b636649b9a99b73b2e03d062611acea3c56
downloadaur-d04b66e36b459218607df02b8002bb438ecd4171.tar.gz
feat: initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD22
-rw-r--r--icon.pngbin0 -> 21475 bytes
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a42954d11936
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = app-outlet-bin
+ pkgdesc = A Universal linux app store
+ pkgver = 1.3.4
+ pkgrel = 1
+ url = https://app-outlet.github.io
+ arch = x86_64
+ license = MIT
+ source = app-outlet-1.3.4.AppImage::https://github.com/app-outlet/app-outlet/releases/download/v1.3.4/App.Outlet-1.3.4.AppImage
+ sha256sums = 81ffabda2dd6f049cd41ac58056463c93197bf19ad8f245b333f2b6cd9914ed5
+
+pkgname = app-outlet-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b02ba1fa152d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2020 App Outlet
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..614be181b9f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: DannyChain <dev@dannychain.anonaddy.me>
+
+_appname=app-outlet
+pkgname=app-outlet-bin
+pkgver=1.3.4
+pkgrel=1
+pkgdesc="A Universal linux app store"
+url="https://app-outlet.github.io"
+arch=("x86_64")
+license=("MIT")
+source=(
+ "${_appname}-${pkgver}.AppImage::https://github.com/app-outlet/app-outlet/releases/download/v${pkgver}/App.Outlet-${pkgver}.AppImage"
+)
+sha256sums=("81ffabda2dd6f049cd41ac58056463c93197bf19ad8f245b333f2b6cd9914ed5")
+
+package() {
+ install -Dm644 ${_appname}.desktop -t "${pkgdir}/usr/share/applications"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${_appname}"
+ install -Dm644 icon.png "${pkgdir}/usr/share/pixmaps/${_appname}.png"
+ install -d "${pkgdir}/opt/${_appname}"
+ cp -r ${_appname}-${pkgver}.AppImage "$pkgdir/opt/${_appname}/${_appname}.AppImage"
+}
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..daacddb2c148
--- /dev/null
+++ b/icon.png
Binary files differ