summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfabrixxm2022-06-05 14:48:15 +0200
committerfabrixxm2022-06-05 14:48:15 +0200
commit92cb9d53f21fb1f6cc824a0174ce733d6c2d8b72 (patch)
treec1f007715a728035bf84aed717027367403d98a7
downloadaur-92cb9d53f21fb1f6cc824a0174ce733d6c2d8b72.tar.gz
First commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f50dba92dea0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = appaya-git
+ pkgdesc = Gnome app to monitor and control Syncthing daemon
+ pkgver = 0.2.0.r3.g83e3108
+ pkgrel = 1
+ url = https://git.sr.ht/~fabrixxm/appaya
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ makedepends = gobject-introspection
+ makedepends = git
+ makedepends = vala
+ makedepends = blueprint-compiler
+ depends = gtk4
+ depends = libadwaita
+ depends = zint
+ provides = appaya
+ conflicts = appaya
+ source = git+https://git.sr.ht/~fabrixxm/appaya
+ sha256sums = SKIP
+
+pkgname = appaya-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31f7e730c9e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+appaya/
+*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a19fdae63624
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Fabrix Xm <fabrix.xm@gmail.com>
+_pkgname=appaya
+pkgname=appaya-git
+pkgver=0.2.0.r3.g83e3108
+pkgrel=1
+pkgdesc="Gnome app to monitor and control Syncthing daemon"
+arch=('x86_64' 'aarch64')
+url="https://git.sr.ht/~fabrixxm/appaya"
+license=(GPL3)
+depends=('gtk4' 'libadwaita' 'zint')
+makedepends=('meson' 'ninja' 'gobject-introspection' 'git' 'vala' 'blueprint-compiler')
+provides=(appaya)
+conflicts=(appaya)
+source=("git+https://git.sr.ht/~fabrixxm/appaya")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson build "$_pkgname"
+ ninja -C build
+}
+
+check() {
+ cd "${srcdir}/build"
+ ninja test
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}