summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonrad Beckmann2020-08-17 12:29:30 +0200
committerKonrad Beckmann2020-08-17 12:32:42 +0200
commit25476167e29a5b19a44f8a61a208d54c7f5275c0 (patch)
tree665d653082698b0e22963b5b3d70d1db229c62a4
downloadaur-25476167e29a5b19a44f8a61a208d54c7f5275c0.tar.gz
appcsxcad-git
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d0adda7fac4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = appcsxcad-git
+ pkgdesc = Minimal GUI Application using the QCSXCAD library. Built from git.
+ pkgver = 20200104
+ pkgrel = 1
+ url = https://github.com/thliebig/AppCSXCAD
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = cmake
+ depends = csxcad-git
+ depends = qcsxcad
+ depends = hdf5
+ depends = vtk
+ depends = qt5-base
+ provides = appcsxcad
+ conflicts = appcsxcad
+ source = git+https://github.com/thliebig/AppCSXCAD
+ md5sums = SKIP
+
+pkgname = appcsxcad-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2837fb3ac6f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Konrad Beckmann <konrad.beckmann@gmail.com>
+
+_pkgname=AppCSXCAD
+pkgname=appcsxcad-git
+pkgver=20200104
+pkgrel=1
+pkgdesc="Minimal GUI Application using the QCSXCAD library. Built from git."
+arch=('x86_64')
+url="https://github.com/thliebig/$_pkgname"
+license=('BSD')
+depends=("csxcad-git" "qcsxcad" "hdf5" "vtk" "qt5-base")
+provides=('appcsxcad')
+conflicts=('appcsxcad')
+makedepends=('git' 'cmake')
+source=("git+https://github.com/thliebig/$_pkgname")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ../
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname/build"
+ make DESTDIR="$pkgdir" install
+}