summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortee2023-08-30 01:06:51 +1200
committertee2023-08-30 01:06:51 +1200
commit2b05856f1af1ea2fb1bf71860676a5d9a66fd23a (patch)
tree1bced58776af10ea3768895c70b67efbf5ee3e31
parentc2bff9aecbd48f0a4a7be6d2e01d0eddfea0dfe7 (diff)
downloadaur-2b05856f1af1ea2fb1bf71860676a5d9a66fd23a.tar.gz
Updated to 0.3.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 29 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88f2a97b9bd1..f580abea01ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = appflowy-bin
- pkgdesc = Open source alternative to Notion
- pkgver = 0.2.9
+ pkgdesc = AppFlowy is an open-source alternative to Notion. You are in charge of your data and customizations.
+ pkgver = 0.3.0
pkgrel = 1
- url = https://www.appflowy.io/
+ url = https://appflowy.io
arch = x86_64
license = AGPL
depends = xdg-user-dirs
@@ -11,7 +11,11 @@ pkgbase = appflowy-bin
depends = openssl-1.1
provides = appflowy
conflicts = appflowy
- source = appflowy-bin-0.2.9.tar.gz::https://github.com/AppFlowy-IO/appflowy/releases/download/0.2.9/AppFlowy_x86_64-unknown-linux-gnu_ubuntu-20.04.tar.gz
- b2sums = a66d1b346359264d3985685f32246f1333ffb95e9bfdd680534a970db26ee728bb56d5013e99ffe1209df12892ded611526935801cff61eb3d1b922a1ccc1856
+ source = https://github.com/AppFlowy-IO/AppFlowy/raw/0.3.0/LICENSE
+ source = https://github.com/AppFlowy-IO/AppFlowy/raw/0.3.0/frontend/scripts/linux_distribution/deb/AppFlowy.desktop
+ source = appflowy-bin-0.3.0.tar.gz::https://github.com/AppFlowy-IO/AppFlowy/releases/download/0.3.0/AppFlowy_x86_64-unknown-linux-gnu_ubuntu-20.04.tar.gz
+ b2sums = 6fa2a6adf165a614637f4aae5b323c427b99c2d13f9ab55eefae012dc3dbeebe5957cd2e2497e4c38426088a41dac89f6ac6284af6cf6a4a67a6780f409e8237
+ b2sums = d5b229bbae978881abc0ea3edb665ddda510072b448f5ba334aea4b54b91cf7a1a5fb9582c127ec0c34626737920cb7b1038387f02565694c2e7a51d2615f779
+ b2sums = a3f4f7b662cbc338535decf402d476c06872893a595a6eaf56ebde2eea33ea57b46ba5a02f9395d3f0ccc55a3b313f3aebabebe7cca248e6010dd96435677445
pkgname = appflowy-bin
diff --git a/PKGBUILD b/PKGBUILD
index 3ef05e7f6ad0..9aa75fd2d639 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,35 @@
-#Maintainer Lucas van Leijen <lvanl at tuta dot io>
+# Maintainer Lucas van Leijen <lvanl at tuta dot io>
+# Maintainer: tee < teeaur at duck dot com >
pkgname=appflowy-bin
_pkgname=appflowy
-pkgver=0.2.9
+pkgver=0.3.0
pkgrel=1
-pkgdesc="Open source alternative to Notion"
+pkgdesc="AppFlowy is an open-source alternative to Notion. You are in charge of your data and customizations."
arch=('x86_64')
-url="https://www.appflowy.io/"
+url="https://appflowy.io"
license=('AGPL')
provides=('appflowy')
conflicts=('appflowy')
depends=('xdg-user-dirs' 'gtk3' 'libkeybinder3' 'openssl-1.1')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/AppFlowy-IO/appflowy/releases/download/${pkgver}/AppFlowy_x86_64-unknown-linux-gnu_ubuntu-20.04.tar.gz")
-b2sums=('a66d1b346359264d3985685f32246f1333ffb95e9bfdd680534a970db26ee728bb56d5013e99ffe1209df12892ded611526935801cff61eb3d1b922a1ccc1856')
+_src="https://github.com/AppFlowy-IO/AppFlowy"
+source=(
+ "${_src}/raw/${pkgver}/LICENSE"
+ "${_src}/raw/${pkgver}/frontend/scripts/linux_distribution/deb/AppFlowy.desktop"
+ "$pkgname-$pkgver.tar.gz::${_src}/releases/download/${pkgver}/AppFlowy_x86_64-unknown-linux-gnu_ubuntu-20.04.tar.gz")
+b2sums=('6fa2a6adf165a614637f4aae5b323c427b99c2d13f9ab55eefae012dc3dbeebe5957cd2e2497e4c38426088a41dac89f6ac6284af6cf6a4a67a6780f409e8237'
+ 'd5b229bbae978881abc0ea3edb665ddda510072b448f5ba334aea4b54b91cf7a1a5fb9582c127ec0c34626737920cb7b1038387f02565694c2e7a51d2615f779'
+ 'a3f4f7b662cbc338535decf402d476c06872893a595a6eaf56ebde2eea33ea57b46ba5a02f9395d3f0ccc55a3b313f3aebabebe7cca248e6010dd96435677445')
+prepare(){
+ sed -i 's|/bin|/share/appflowy|' AppFlowy.desktop
+ sed -i 's|Icon=.*|Icon=/usr/share/appflowy/data/flutter_assets/assets/images/flowy_logo.svg|' AppFlowy.desktop
+}
package(){
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${_pkgname}"
+ install -Dm644 AppFlowy.desktop -t "$pkgdir/usr/share/applications"
cd AppFlowy
install -dDm755 "$pkgdir"/{usr/share/"$_pkgname",usr/bin}
cp -a * "$pkgdir/usr/share/$_pkgname/"
ln -s "/usr/share/$_pkgname/AppFlowy" "${pkgdir}/usr/bin/$_pkgname"
- install -Dm644 "$srcdir/AppFlowy/$_pkgname.desktop.temp" "$pkgdir/usr/share/applications/$_pkgname.desktop"
- sed -i "4 s/\[CHANGE_THIS\]\/AppFlowy/\/usr\/share\/$_pkgname/" "$pkgdir/usr/share/applications/$_pkgname.desktop"
- sed -i "5 s/\[CHANGE_THIS\]\/AppFlowy\/AppFlowy/\/usr\/bin\/$_pkgname/" "$pkgdir/usr/share/applications/$_pkgname.desktop"
-} \ No newline at end of file
+}