summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortee2023-09-05 02:29:49 +1200
committertee2023-09-05 02:29:49 +1200
commitcfee0f3234551269d06e5d28db3866bfa7b9757c (patch)
tree8f448c71c4da3bf2ca0b30aadb44b78c25aebf4b
parent2b05856f1af1ea2fb1bf71860676a5d9a66fd23a (diff)
downloadaur-cfee0f3234551269d06e5d28db3866bfa7b9757c.tar.gz
Updated to 0.3.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f580abea01ea..2cf86b8aea15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = appflowy-bin
pkgdesc = AppFlowy is an open-source alternative to Notion. You are in charge of your data and customizations.
- pkgver = 0.3.0
+ pkgver = 0.3.1
pkgrel = 1
url = https://appflowy.io
arch = x86_64
@@ -11,11 +11,11 @@ pkgbase = appflowy-bin
depends = openssl-1.1
provides = appflowy
conflicts = appflowy
- source = https://github.com/AppFlowy-IO/AppFlowy/raw/0.3.0/LICENSE
- source = https://github.com/AppFlowy-IO/AppFlowy/raw/0.3.0/frontend/scripts/linux_distribution/deb/AppFlowy.desktop
- source = appflowy-bin-0.3.0.tar.gz::https://github.com/AppFlowy-IO/AppFlowy/releases/download/0.3.0/AppFlowy_x86_64-unknown-linux-gnu_ubuntu-20.04.tar.gz
+ source = https://github.com/AppFlowy-IO/AppFlowy/raw/0.3.1/LICENSE
+ source = https://github.com/AppFlowy-IO/AppFlowy/raw/0.3.1/frontend/scripts/linux_distribution/deb/AppFlowy.desktop
+ source = appflowy-bin-0.3.1.tar.gz::https://github.com/AppFlowy-IO/AppFlowy/releases/download/0.3.1/AppFlowy_x86_64-unknown-linux-gnu_ubuntu-20.04.tar.gz
b2sums = 6fa2a6adf165a614637f4aae5b323c427b99c2d13f9ab55eefae012dc3dbeebe5957cd2e2497e4c38426088a41dac89f6ac6284af6cf6a4a67a6780f409e8237
b2sums = d5b229bbae978881abc0ea3edb665ddda510072b448f5ba334aea4b54b91cf7a1a5fb9582c127ec0c34626737920cb7b1038387f02565694c2e7a51d2615f779
- b2sums = a3f4f7b662cbc338535decf402d476c06872893a595a6eaf56ebde2eea33ea57b46ba5a02f9395d3f0ccc55a3b313f3aebabebe7cca248e6010dd96435677445
+ b2sums = 4e0e66b358b22acae50ee4d4c0e478bf88776d3076837f9303e96b03dae739570f16a70df57f808eca3b0db40bfc609382ca6dcc969c7cb8ed1163b0f5fa6538
pkgname = appflowy-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9aa75fd2d639..390cc26a03df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=appflowy-bin
_pkgname=appflowy
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
pkgdesc="AppFlowy is an open-source alternative to Notion. You are in charge of your data and customizations."
arch=('x86_64')
@@ -19,17 +19,17 @@ source=(
"$pkgname-$pkgver.tar.gz::${_src}/releases/download/${pkgver}/AppFlowy_x86_64-unknown-linux-gnu_ubuntu-20.04.tar.gz")
b2sums=('6fa2a6adf165a614637f4aae5b323c427b99c2d13f9ab55eefae012dc3dbeebe5957cd2e2497e4c38426088a41dac89f6ac6284af6cf6a4a67a6780f409e8237'
'd5b229bbae978881abc0ea3edb665ddda510072b448f5ba334aea4b54b91cf7a1a5fb9582c127ec0c34626737920cb7b1038387f02565694c2e7a51d2615f779'
- 'a3f4f7b662cbc338535decf402d476c06872893a595a6eaf56ebde2eea33ea57b46ba5a02f9395d3f0ccc55a3b313f3aebabebe7cca248e6010dd96435677445')
+ '4e0e66b358b22acae50ee4d4c0e478bf88776d3076837f9303e96b03dae739570f16a70df57f808eca3b0db40bfc609382ca6dcc969c7cb8ed1163b0f5fa6538')
prepare(){
- sed -i 's|/bin|/share/appflowy|' AppFlowy.desktop
+ sed -i 's|/bin/AppFlowy|/bin/appflowy|' AppFlowy.desktop
sed -i 's|Icon=.*|Icon=/usr/share/appflowy/data/flutter_assets/assets/images/flowy_logo.svg|' AppFlowy.desktop
}
package(){
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${_pkgname}"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
install -Dm644 AppFlowy.desktop -t "$pkgdir/usr/share/applications"
cd AppFlowy
install -dDm755 "$pkgdir"/{usr/share/"$_pkgname",usr/bin}
cp -a * "$pkgdir/usr/share/$_pkgname/"
- ln -s "/usr/share/$_pkgname/AppFlowy" "${pkgdir}/usr/bin/$_pkgname"
+ ln -s "/usr/share/$_pkgname/AppFlowy" "$pkgdir/usr/bin/$_pkgname"
}