summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMithicSpirit2024-02-29 23:03:10 -0500
committerMithicSpirit2024-02-29 23:03:10 -0500
commit091e6336a71f6725aef4490d4a46a9e5581304b2 (patch)
tree319e6e6985a21a0315b505ec68d91ae7469be441
parente9c23c1096e56e5a41d9f346775a879f5a889df1 (diff)
downloadaur-091e6336a71f6725aef4490d4a46a9e5581304b2.tar.gz
use deps for cargo-make, duckscript
Instead of building them from source every time
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 000838aa45db..81f23d44ae3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = appflowy-git
pkgdesc = An open-source alternative to Notion.
pkgver = latest
- pkgrel = 16
+ pkgrel = 17
url = https://www.appflowy.io/
arch = x86_64
license = AGPL3
@@ -24,7 +24,7 @@ pkgbase = appflowy-git
conflicts = appflowy-bin
options = !lto
source = appflowy::git+https://github.com/AppFlowy-IO/AppFlowy.git
- source = flutter::git+https://github.com/flutter/flutter.git#tag=3.18.0-0.2.pre
+ source = flutter::git+https://github.com/flutter/flutter.git#tag=3.19.2
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d5afa37d45e6..ab03488b1b9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
_pkgname=appflowy
pkgname=$_pkgname-git
pkgver=latest
-pkgrel=16
+pkgrel=17
pkgdesc='An open-source alternative to Notion.'
arch=(x86_64)
url='https://www.appflowy.io/'
license=('AGPL3')
depends=('glibc>=2.32' gtk3 libkeybinder3 xdg-user-dirs libnotify)
-makedepends=(git clang cmake ninja unzip rustup cargo sqlite rsync)
+makedepends=(git clang cmake ninja unzip rustup cargo sqlite rsync cargo-make duckscript)
provides=($_pkgname)
conflicts=($_pkgname $_pkgname-bin)
replaces=()
@@ -17,7 +17,7 @@ backup=()
options=(!lto)
install=
source=("$_pkgname::git+https://github.com/AppFlowy-IO/AppFlowy.git"
- 'flutter::git+https://github.com/flutter/flutter.git#tag=3.18.0-0.2.pre')
+ 'flutter::git+https://github.com/flutter/flutter.git#tag=3.19.2')
sha256sums=('SKIP'
'SKIP')
@@ -50,8 +50,6 @@ build() {
_setenv
cd "$srcdir/$_pkgname/frontend"
- cargo install cargo-make
- cargo install duckscript_cli
cargo make appflowy-flutter-deps-tools
cargo make --profile "production-linux-$CARCH" appflowy