summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMithicSpirit2022-05-25 11:10:49 -0400
committerMithicSpirit2022-05-25 11:10:49 -0400
commit5c31fd16c5a6b5a0fa60b9238c95b58e914325b0 (patch)
tree005c227b46dcb6777e2a5da865446ae6acd205c4
parent5d759cb8927e44ea890d6b93fe0cf3aa8260f9d1 (diff)
downloadaur-5c31fd16c5a6b5a0fa60b9238c95b58e914325b0.tar.gz
Unpin flutter version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9987c5d9821c..3a24f23e7da5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = appflowy-git
pkgdesc = An open-source alternative to Notion.
pkgver = latest
- pkgrel = 2
+ pkgrel = 3
url = https://www.appflowy.io/
arch = x86_64
license = AGPL3
@@ -20,7 +20,7 @@ pkgbase = appflowy-git
conflicts = appflowy
conflicts = appflowy-bin
source = appflowy::git+https://github.com/AppFlowy-IO/AppFlowy.git
- source = flutter::git+https://github.com/flutter/flutter.git#tag=2.10.5
+ source = flutter::git+https://github.com/flutter/flutter.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ce02cb34a3cf..846f0df0550e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=appflowy
pkgname=$_pkgname-git
pkgver=latest
-pkgrel=2
+pkgrel=3
pkgdesc='An open-source alternative to Notion.'
arch=(x86_64)
url='https://www.appflowy.io/'
@@ -17,7 +17,7 @@ backup=()
options=()
install=
source=("$_pkgname::git+https://github.com/AppFlowy-IO/AppFlowy.git"
- 'flutter::git+https://github.com/flutter/flutter.git#tag=2.10.5')
+ 'flutter::git+https://github.com/flutter/flutter.git')
sha256sums=('SKIP' 'SKIP')
_setpath() {
@@ -35,6 +35,9 @@ prepare() {
cd "$srcdir/$_pkgname/frontend"
sed -i "/rustup/d" scripts/makefile/env.toml
+ cd "$srcdir/$_pkgname/frontend/app_flowy"
+ flutter pub add charcode
+
flutter config --enable-linux-desktop
}